How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Chad Farhat Your Own Question
Chad Farhat
Chad Farhat, ASE Certified Technician A6 - Electrical / Electronic systems A7 Heating / Air conditioning systems
Category: Kia
Satisfied Customers: 1214
Experience:  Owner at Carolina Auto Service & Sales , 20 years Experience in Foreign & Domestic vehicles
Type Your Kia Question Here...
Chad Farhat is online now
A new question is answered every 9 seconds

The warning alarm keeps going off on my Kia optima 2007. I

Customer Question

The warning alarm keeps going off on my Kia optima 2007. I took out the fuses and now the turn signals won't work. What can I do?
Submitted: 3 months ago.
Category: Kia
Expert:  Chad Farhat replied 3 months ago.

Hi, I' m Chad. Welcome to JustAnswer. I' m reviewing your question now, and I will be post back with your reply ASAP

Do you have one or 2 keys for it ?

Is the security light flashing or steady on ?

if it is , try the below procedure

Try this below procedure an

Master Reset Procedure

1-Disconnect battery ( Both Cables ,The Negative & The Positive Cable )
2-Touch Cables together and hold 20 secs and let go
3-Hold Brake pedal down 10 secs
4-Wait 10 minutes and then Reconnect Battery
5-Close all the doors ,hood & trunk .
6-lock the car with key from driver door ( IF your car is Equipped with a bladeless key then just locked with the keyFob
7- Unlock car & Start your vehicle

hopefully this will reset the alarm module for now , if not, we need to have a diagnostic scan to retrieve fault codes from antitheft module and see which component is bad , is it the key, the receiver,the antitheft module etc ...

Please let me know

Thank You ***** ( aka -Customer)

ASE Certified Tech

Customer: replied 3 months ago.
I had to go to the store; so I put the fuses back in and when I got back it didn't do it any more. Some sensor must be btad. I'll try your reset if it happens again. thank you
Expert:  Chad Farhat replied 3 months ago.

well that great m but need more help let me know

Hope I was helpfull to you , Please let me know if you need anything else on it

A Positive Rating is Much Aprecciated

This Post Will Stay Open For You to Come Back and ask me any Follow up Questions you may have on this issue Even after you Rate Me.

Thank You

Chad Farhat ( aka -Customer)
ASE Certified Technician

Related Kia Questions