How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Ron Your Own Question
Ron, ASE Certified Technician
Category: Kia
Satisfied Customers: 33093
Experience:  35 years as an automotive tech
Type Your Kia Question Here...
Ron is online now
A new question is answered every 9 seconds

I have a 2012 Kia optima that I have had and a half years.

Customer Question

Hello. I have a 2012 Kia optima that I have had for 3 and a half years. 40k kl. On the eng. Will I start to get a vibration that I can feel in my brake peddle, steering wheel and car seat when I put it in gear in non moving position if I don't Chang the transm oil?
JA: Does the engine turn over? How old is the battery?
Customer: The battery is new and the car always starts.
JA: Are you hoping to fix this yourself? What have you tried so far?
Customer: What happened was I took my optima to a kia dealership to have a mentaince done. And when I got my car back it was having this problem.
JA: Anything else you think the mechanic should know?
Customer: Yes I think they should check the trans fluid and or it conld be the A/C compr. I don't know. I have taken it back twice. Not fixed.
JA: OK. Got it. I'm sending you to a secure page on JustAnswer so you can place the $5 fully-refundable deposit now. While you're filling out that form, I'll tell the Kia Mechanic about your situation and then connect you two.
Submitted: 4 months ago.
Category: Kia
Expert:  Ron replied 4 months ago.

Hello, my name is ***** ***** I am a professional here at Just Answer. I have noticed that your question was not getting a response and thought I would see if you still need help with this.I apologize for the delay and I hope I can still assist you with this here.

The type of vibration you are describing can be caused by a bad engine mount in most cases or an engine idle concern causing the idle speed to be to low. Since you say it stated after the service done on it, I would return to the shop that did the service work for you and have then check the engine idle speed as well as all the engine mounts.

Related Kia Questions