How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask mike switzer Your Own Question
mike switzer
mike switzer,
Category: Kia
Satisfied Customers: 454
Experience:  lead diagnostic tech at Aamco
93239347
Type Your Kia Question Here...
mike switzer is online now
A new question is answered every 9 seconds

Daniel, I just picked up a new PCM 2002 Sportage and

Customer Question

Daniel, I just picked up a new PCM for my 2002 Sportage and installed it. Engine Still Misses on two cylinders. 1&3. what now?
Submitted: 6 months ago.
Category: Kia
Expert:  mike switzer replied 6 months ago.
hello my name is ***** ***** but if you would allow me to help you i will do my best. if you can get me caught up as to why you replaced the ecm. and what all else has been done.
Customer: replied 6 months ago.
i have a 2002 KIA Sportage 2whd with 2.0L eng. it ran fine until we changed oil and spark plugs. now it will start and run on 2 cylinders. OBD2 codes come up 300,301,303. I changed both coils. still the same. revved a little and got a 604 code. checked crank sensor- it works. ordered andinstalled a new PCM. still no change in codes and misses the same.
Expert:  mike switzer replied 6 months ago.
well i have a feeling that this has nothing to do with the pcm since this started after changing the spark plugs. what brand spark plugs did you install into the engine?
Customer: replied 6 months ago.
installed standard call-out NGK 2756. when the engine missed i took the plugs back to auto-parts to test. they found 2 with a weak spark and replaced them ,so all 4 have a good spark. eng. still missed
Expert:  mike switzer replied 6 months ago.
the most common on those vehicles is the wiring for the coils breaks and cracks when it is messed with. do you have a volt meter for simple testing?
Customer: replied 6 months ago.
i have a Fluke. have checked the coil wires,and the voltage to each coil. When i had the coils off i tested them and found over 3.2 ohms on the primary circuit. replaced both coils and made sure they "snap" on the the plugs below them.
Expert:  mike switzer replied 6 months ago.
it could be on the ground circuit aswell that is bad. so you had voltage at each of the white/red wire?
Customer: replied 6 months ago.
tested voltage from the harness plugs at the coil. 12V. also used a test light and watched the other wire pulse. both coils are firing for cyls 2 and 4. have pulled the plugs twice - both times 1 and 3 look brand new never been fired. 2 and 4 plugs show carbon from firing.
Customer: replied 6 months ago.
i have also checked the coil harness connection at the back of the engine.
Expert:  mike switzer replied 6 months ago.
have you un wound the coil harness to inspect the wiring. the coil harness going bad is a very common problem on these engines.
Customer: replied 6 months ago.
did not. there was a bad spot on the outer covering of the coil harness where it bent around the alum. housing near the front coil. iI inspect the wires inside and found the wire coating OK. put Gorilla tape on the the outer covering.
Expert:  mike switzer replied 6 months ago.
you should check the entire harness.
Customer: replied 6 months ago.
I can do that. so tell me why is there a consistent spark from both coils to 2 and 4 only. this is why i changed the ECM. if I had a bad harness , the spark would be erratic or not at all .
Expert:  mike switzer replied 6 months ago.
the 300 is showing that there may be a couple "half" misfires on the other two cylinders. you would have to confirm it with a scanner that shows live data.
Customer: replied 6 months ago.
301 and 303 are telling me which cyls are misfiring?
Expert:  mike switzer replied 6 months ago.
it is recognizing that those cylinders are misfiring way more than the others.
Customer: replied 6 months ago.
i will remove the coil harness and give a good visual. any other ideas? we can continue tomorrow.
Expert:  mike switzer replied 6 months ago.
another thing that could cause it is the fuel pressure regulator
Expert:  mike switzer replied 6 months ago.
but it is unlikely the coil harness is more likely
Customer: replied 6 months ago.
thanks more tommorrow
Expert:  mike switzer replied 6 months ago.
any chance on checking that harness?

Related Kia Questions