How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Kiatech Your Own Question
Kiatech
Kiatech, Kia Master Technician
Category: Kia
Satisfied Customers: 210
Experience:  30+ years experience,ASE certified,KIA certified Master Technician,Ford factory trained
32162675
Type Your Kia Question Here...
Kiatech is online now
A new question is answered every 9 seconds

Kia Sephia: I have a 1999 Kia Sephia... I was driving the car

Customer Question

I have a 1999 Kia Sephia... I was driving the car and started to slow down to turn into a driveway when then OD light on the dash came on and the trans acted like it was in neutral... I looked down at the shifter and it was in drive... I stopped the car and put it in park and back into drive and it had nothing. I ttried reverse and drive and even tried 1st and 2nd and it acts like it is in neutral...
Submitted: 1 year ago.
Category: Kia
Expert:  EricFromCT replied 1 year ago.
Did you check the transmission fluid level yet?
Customer: replied 1 year ago.
Yes I checked the trans fluid...
Customer: replied 1 year ago.
If the fluid was low, it would slip or show some sign of slipping...it showed absolutely no warning signs of any problems whatsoever... the OD light came on and it immediately acted like the trans was in neutrel
Customer: replied 1 year ago.
I would like an answer to my question, my account has been charged and all I got from you was did you check your fluid... I have 35 yrs in the automotive field , the first thing I did was check the fluid... I'm waiting on you
Expert:  EricFromCT replied 1 year ago.
Sorry for the delay. It is probable that something has failed inside the transmission. You can have the computer checked to see which code is stored. Does the trans engage the parking pawl when in park? If there is nothing obvious like those things then you can check the line pressure at the ports. I should have all the specs for that.
Customer: replied 1 year ago.
The trans did not make a noise... still doesn't... it's like the trans went in neutral... park gear works but that's it... I put a new range selector/neutral safety switch on it... I dropped the pan to see if the shifter was working in the valve body and to check for anything foreign in the pan... everything looked great... don't know where to go from here... the car has 38,000 original miles on it... it wouldn't seem like it would have a bad trans already...
Customer: replied 1 year ago.
I don't under stand the lack of communication with just answer.com... I have been nearly a week getting a response from a tech and when I finally do get a response, he asks me if I checked the trans fluid... the second second response was a few days later and he tells me that me transmission was broke with no details... I have used just answer in the past on the Chrysler forum and the gentleman that they connected me with was very helpful and stayed with me until my problem was solved... I am very dissatisfied with my experience this time... My bank account reflects that the full amount was taken out of it which I don't believe is right... the $5 was on the honor system and the rest is supposed to be taken out after I have talked with a tech and was satisfied with my service... I've waited days for a response and by no means am I satisfied...
Expert:  EricFromCT replied 1 year ago.
Sorry the confusion you are having, but I dont think we are on the same time schedule. I am on Eastern time and go offline around 6 or 7 pm.
Expert:  EricFromCT replied 1 year ago.
Do you have a line pressure gauge? At this point you need to check the line pressure of the transmission. The input shaft for the pump may have broken. Can you check the line pressure?