How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Reggie Whiddon Your Own Question
Reggie Whiddon
Reggie Whiddon, Auto Mechanic
Category: Kia
Satisfied Customers: 110
Experience:  Lead tech at river regions auto
90546729
Type Your Kia Question Here...
Reggie Whiddon is online now
A new question is answered every 9 seconds

Air conditioner blowing warm air. JA: Sometimes things that

Customer Question

Air conditioner blowing warm air.
JA: Sometimes things that you think will be really complicated end up being easy to fix with Kia. The Kia Mechanic I'm going to connect you with knows all the tricks and shortcuts. Tell me a bit more about what's going on so he can help you best.
Customer: 2012 Kia Optima. Air conditioner doesn't appear to be working ie air blowing from vents is warm not cold.
JA: Are you hoping to fix this yourself?
Customer: Yes. Car has 103, 000 miles on it.
JA: Great! What have you tried so far?
Customer: Recharging it with freon however low pressure line was way over pressure (>100psi)
JA: Is there anything else the Kia Mechanic should be aware of about your Kia?
Customer: Ac lines are warm not cold after idling engine on high with ac turned on max for 15 minutes
JA: OK. Got it. I'm sending you to a secure page on JustAnswer so you can place the $5 fully-refundable deposit now. While you're filling out that form, I'll tell the Kia Mechanic about your situation and then connect you two.
Submitted: 8 months ago.
Category: Kia
Expert:  Reggie Whiddon replied 8 months ago.
Hi there thanks for thr question. Do you know or not if your compressor is running and how about thr cooling fans
Customer: replied 8 months ago.
I believe it is. I can hear a difference in engine load when turning o the ac. Also feel hot engine air difference in engine compartment when on.
Customer: replied 8 months ago.
Are you still researching problem?
Customer: replied 8 months ago.
Can I get some feedback?
Customer: replied 8 months ago.
How long do I have to wait for a response? You have asked one question to which I replied.
Customer: replied 8 months ago.
I'm going to tell Visa to cancel this order if I don't hear anything back from you in the next 15 minutes. At this point I'm thinking I have been scammed.
Expert:  Reggie Whiddon replied 8 months ago.
Sir in here
Expert:  Reggie Whiddon replied 8 months ago.
Forgive me I live in thr south and we are in thr middle of a bad storm
Expert:  Reggie Whiddon replied 8 months ago.
Sir you have not been scammed let's fix your car
Expert:  Reggie Whiddon replied 8 months ago.
Oksy you say the compressor is coming on. The pipes that go inside thr car there is a small one and big one. With ac on engine running is the small pipe getting cold
Expert:  Reggie Whiddon replied 8 months ago.
Sir did you cancel on me? Anyway I meant thr big pipe is it getting cold, the small one should be hot. Knowing this will help us determine if we possibly have a problem with thr temp door or actuator
Customer: replied 8 months ago.
Both pipes are warm to hot after being on max cold for 10 minutes.
Customer: replied 8 months ago.
Are you there?
Expert:  Reggie Whiddon replied 8 months ago.
Expert:  Reggie Whiddon replied 8 months ago.
Okay if both pipes are warm the compressor may not be coming on or it has failed can u see the compressor
Expert:  Reggie Whiddon replied 8 months ago.
Do you have gauges to hook up to ac
Expert:  Reggie Whiddon replied 8 months ago.
I see a lot of kias in for this and I real common problem is thr magnetic clutch on the compressor
Customer: replied 8 months ago.
Gauge on low pressure line reads >100 psi.
Customer: replied 8 months ago.
What can I do?
Customer: replied 8 months ago.
What diagnostic test can I do to see if this is the problem? Could it be due to the evaporative cooler?
Expert:  Reggie Whiddon replied 8 months ago.
No. You mentioned something about the pressure do u have gauges
Expert:  Reggie Whiddon replied 8 months ago.
Actually around 100 psi would be normal with thr compressor not running.
Expert:  Reggie Whiddon replied 8 months ago.
If you can see thr compressor have someone turn it on so you can see if thr clutch is engaging
Customer: replied 8 months ago.
It looks like the clutch is engaging but hard to say for sure.
Customer: replied 8 months ago.
It's rotating all the time
Expert:  Reggie Whiddon replied 8 months ago.
Do you have gauges
Customer: replied 8 months ago.
I don't have gauges for both high and low pressure lines. Only the low pressure line when I tried filling with freon (>100 psi)
Expert:  Reggie Whiddon replied 8 months ago.
Did you try looking at thr compressor while someone turned thr ac on and off
Customer: replied 8 months ago.
it appears to always turn but at different rates when on vs off. My dads Kia does the same.
Expert:  Reggie Whiddon replied 8 months ago.
Ok. If it is coming on and both thr pipes are hot we are gonna need those gauges
Expert:  Reggie Whiddon replied 8 months ago.
we can diagnose whether it is a bad compressor or expansion valve
Customer: replied 8 months ago.
Ok. I'm going to go get them Be back in 30-45 minutes
Expert:  Reggie Whiddon replied 8 months ago.
Okay I will be checking in with you
Customer: replied 8 months ago.
Low side was >100 psi, high side was in the normal range 125 psi. Temperature is about 75F.
Expert:  Reggie Whiddon replied 8 months ago.
Okay if your compressor is coming on its bad, it isn't pumping
Expert:  Reggie Whiddon replied 8 months ago.
With the ac on and working properly you would see 25 to 40 on low and 225 275 on high
Expert:  Reggie Whiddon replied 8 months ago.
Do this watch your gauges and see whst thr pressure does as you cut the ac on and off
Expert:  Reggie Whiddon replied 8 months ago.
When ac is off pressures shoukd equalize and be around 100 psi on both sides
Expert:  Reggie Whiddon replied 8 months ago.
Once you turn on ac thr high will rise and low side will lower, with your pressures it would indicate the compressor isn't pumping although it did rise by 25 psi on high side
Expert:  Reggie Whiddon replied 8 months ago.
Your next move is to confirm that the compressor is engaging, you can do that by watching pressures when the ac is turned on if it's engaging. Go get a compressor kit from advance, and I will help you put it on you will save as much as 5 to 700
Customer: replied 8 months ago.
I tried everything you suggested. Gushes did not move (low still above 100 before turning engine on, and while running with or without ac). I decided to turn engine off and evacuate all the air from the low by pushing in the pin with a screw driver. No freon came out at all suggesting no freon in the system. Now when I ran the system with ac on or off pressure stayed low in low line, but high pressure was also low. Decided to try to fill low with freon. I didn't add much, maybe 10-15% of can and low went very high again while high stayed low (80-100psi). What's this telling you?
Customer: replied 8 months ago.
Nothing really seems to happen to the pressure gauges when I turn the ac on or off.
Expert:  Reggie Whiddon replied 8 months ago.
Good morning
You say thr low went very high, how high? It sounds to me like your compressor isn't coming on. I'm about to look at circuit for thr compressor I will be rigjt back
Expert:  Reggie Whiddon replied 8 months ago.
Locate the ac compressor relay in thr underhood fuse box it will be labeled. Remove that relay and using a jumper wire bypass the relay sending 12 volts down to thr compressor this will force it to come on. Thr relay pins will be numbered jump 30 to 87
Expert:  Reggie Whiddon replied 8 months ago.
If it comes on and starts cooling were gonna need a scantool. But a real common part for that probkem is thr evaporater temp sensor
Customer: replied 8 months ago.
The low was over 100 psi. I added an image of my fuse box. Can you tell me which one?
Customer: replied 8 months ago.
Btw, I really appreciate all your help Reggie!
Expert:  Reggie Whiddon replied 8 months ago.
Sir I do apologize my laptop crashed today, hard drive I beleive, all my programming software everything.
Expert:  Reggie Whiddon replied 8 months ago.
I do appreciate your patience I am trying to open your pic
Expert:  Reggie Whiddon replied 8 months ago.
Okay thr fuse that's labeled acon and the relay HAC
Expert:  Reggie Whiddon replied 8 months ago.
R u online now
Customer: replied 8 months ago.
Ok, I see the fuses. What should I do next?
Expert:  Reggie Whiddon replied 8 months ago.

first make sure the fuse is good and that relay pull it out the blades coming out of it should have numbers 85 86 30 87

you want to take a jumper and put between 87 and 30 that will make the compressor run if not take a test light and make sure you have power at both leads if you do go down to the compressor and make sure you have 12 volts coming in if you do compressor is bad

Expert:  Reggie Whiddon replied 8 months ago.

good morning my friend, I am online, computer repaired lets get you some ac today. That relay may be numbered different two of the blades should be larger than the other 2 the large ones are we are working.

Expert:  Reggie Whiddon replied 8 months ago.

I need to know a couple things there are 2 different systems on your car do you have automatic or manual air conditioning and your engine size

Customer: replied 8 months ago.
Engine size is I-4 2.4L 200-hp. I believe the air conditioner can operate under automatic conditions. I took a picture of my a/c unit (attached).
Customer: replied 8 months ago.
you want to take a jumper and put between 87 and 30 that will make the compressor"...Does this mean connect the two outlets with a wire and I should here the compressor turn on at this point?
Customer: replied 8 months ago.
Picture of HAC fuse attached. I see all the numbers you mentioned.
Expert:  Reggie Whiddon replied 8 months ago.

No sir hold on that you have the premiere automatic ac system, hold till i finish looking at circuit

Expert:  Reggie Whiddon replied 8 months ago.
call me it will be easier
Customer: replied 8 months ago.
Tried calling but you were out and mailbox was full. My number is(###) ###-####cell or(###) ###-####wk
Customer: replied 8 months ago.
Scan tool Launch Creader VII+?
Expert:  Reggie Whiddon replied 8 months ago.

Launch Idiag its a little yellow connector works bluetooth with your cellphone or tablet

Expert:  Reggie Whiddon replied 8 months ago.

here is something to consider the dealership would charge you somewhere between 2 and 300 dollars just to diagnose the problem. That scanner will cost you less than half that and the next time you need it it will be paying you

Customer: replied 8 months ago.
I see something about having to pay for software after registering x431 auto diag. They say there's also free software (OBDII).
Customer: replied 8 months ago.
Is this the correct scan tool? (Attached)
Expert:  Reggie Whiddon replied 8 months ago.

sir how did you find that? OMG i thought those were all pulled.. Sir yes you have to buy each carline at about 67 a piece but its lifetime, and get this you have full functionality you can clear codes activate devices, make adjustments, coding everything there 5000 dollar scanner does, i will warnyou it might say us but its actually china but thats cool, I didnt know they made it in apple. Sir if that is what i think it is, buy it immediately

Customer: replied 8 months ago.
That one was not available. Will this one work (attached)?
Expert:  Reggie Whiddon replied 8 months ago.

yes that is actually the one i was telling you about, now they offer two of those one of them comes with 3 free carlines and i beleive the other doesnt

Customer: replied 8 months ago.
Ok, I ordered it but it's not scheduled for delivery until next Friday May 13 th. I will contact you after receiving it. Thanks!
Expert:  Reggie Whiddon replied 8 months ago.

Okay please do and if for some reason i dont catch you on here call me and we will tallk on here. Its our busy season. Thanks

Customer: replied 8 months ago.
Hi Reggie, I finally got the launch scan tool to help diagnose the AC problem. I registered the device and downloaded the appropriate Kia Optima software. Call me or reply to let me know what I should do next.(###) ###-#### *****! Dan
Customer: replied 8 months ago.
Reggie, I'm still waiting for your reply. Dan
Expert:  Reggie Whiddon replied 8 months ago.

be right wit you you got those codes.

Customer: replied 8 months ago.
C1611(CAN timeout EMS)
Intake potentiometer 6.27%Was I supposed to do this test with the engine running/AC on?
Customer: replied 7 months ago.
Today's scan with engine and a/c on.
Expert:  Reggie Whiddon replied 7 months ago.

Good morning I am reviewing your information now, i apologize i recently got custody of my 12 year old daughter and have had alot to do getting her settled. Give me a few minutes be right back

Expert:  Reggie Whiddon replied 7 months ago.

That code C1611 what module was it stored in? And did you do a reset and clearing of all codes. With your scanner do the quick test it will give you the option to clear codes clear them and after go out to your battery disconnect both cables and clamp them together, while there clamped together cycle your key through all position if you have push button push the button and hold it for a few seconds, then go back out to battery unclamp the cables from each other make sure that you have rubbed them and they have made good contact now seperate and hook the positive up first.

Expert:  Reggie Whiddon replied 7 months ago.

And then after that start car and turn ac on if it is not cooling send me a pic of all data in the module it could be called climate control, or HVAC . What we want to see is the temperature inside, outside, evap temp the request for compressor compressor status all of it.

Customer: replied 7 months ago.
Hi Reggie, I did everything you told me to do. AC still not cooling. I've attached three image files of the AC report. What next?
Customer: replied 7 months ago.
Reggie, we are in a heat wave out here in California. I drive 1 hr each way to work, so I need to get my AC working. Please help asap. Thanks! Dan
Expert:  Reggie Whiddon replied 7 months ago.

sir been on lake i got you today we do something thank for patience

Customer: replied 7 months ago.
Reggie, did you view the 3 attachments I sent yesterday? Was this helpful, in terms of helping you with your diagnosis?
Expert:  Reggie Whiddon replied 7 months ago.

Is that all the data in the module

Expert:  Reggie Whiddon replied 7 months ago.

It looks like your evap temp sensor is alot higher than normal, im going to get a location on that so you can go to it and test it

Customer: replied 7 months ago.
that was all the data in the AC module
Expert:  Reggie Whiddon replied 7 months ago.

How about codes any codes reset

Expert:  Reggie Whiddon replied 7 months ago.

Okay i have checked the information we want is split up some of it is in the engine control module, access it and look for compressor data you will see if it is requested and if it has been commanded on..

Customer: replied 7 months ago.
I sent codes in previous message. There didn't seem to be any major codes indicating an AC problem but you should go through them. I reset all the codes per your advice.
Expert:  Reggie Whiddon replied 7 months ago.

yes sir i just wondered if they had reset okay looking at your data i beleive your problem is going to be the evap temp sensor

Expert:  Reggie Whiddon replied 7 months ago.
  • CONTACT REPAIR HOTLINE

  • HOW TO USE DIRECT-HIT

  • 1

    LATEST UPDATES

  • EXPAND YOUR KNOWLEDGE

HOME

SEARCH FIXES

SERVICE MANUALS

MAINTENANCE

ESTIMATING

HOTLINE

MY SHOP

MY DIRECT-HIT

BOOKMARKS

Search

Information Available

Logout

Referral

New Vehicle

Can't Find Service Manual Info?

Post Fix

2012 Kia Optima LX 2.4L, L4, Gas, Asp N, VIN 7, GDI, USATom Beadel - Christian Brothers Automotive

Hotline Archive

With Service Manuals diagrams, components, TSBs, and R&R procedures

Number:559484

Vehicle Application:

2012 Optima 2.0

2012 Optima 2.4

Customer Concern:The Air Conditioning (A/C) does not work. There are no codes. If we jump the relay, the compressor comes on and it cools. The blower works on all speeds.

Average Reported Mileage:91382

Tests/Procedures:1. Use a scan tool to check the A/C commands in the Engine Control Module (ECM) with the engine running, the blower motor on and the A/C switch on.

2. If it shows the A/C switch on, the A/C off and the relay off, test the evaporator temperature sensor.

3. Disconnect the control head. Backprobe and check the evaporator temperature sensor resistance. The specification is 27.6 kilo ohms at 32°F, 18.07 kilo ohms at 50°, 12.11 kilo ohms at 68°, 8.3 kilo ohms at 86°, and 5.8 kilo ohms at 104°F. If the evaporator temperature sensor is out of specification, it has likely failed.

4. Check connection at the sensor as well.

Author:

Potential Causes

With Service Manuals diagrams, components, TSBs, and R&R procedures

Air Conditioner (A/C) Evaporator Temperature Sensor

Evaporator Temperature Sensor Wiring

Confirmed Fix Summary

Confirmed Fix

With Service Manuals diagrams, components, TSBs, and R&R procedures

1 - Replaced Air Conditioning (A/C) Compressor

1 - Replaced Air Conditioner (A/C) Evaporator Temperature Sensor

Confirmed Fix Details

TechReported Fix DetailsConfirmed Fix

1Charlie Alred
July 31, 20152012 Kia Optima, EX 2.4L, L4, Gas, Asp N, VIN 7, MFI, Theta II - PZEV, USA *
Air Conditioner (A/C) Evaporator Temperature Sensor
91,382 milesReplaced Air Conditioner (A/C) Evaporator Temperature Sensor

1CARMAX Technician
January 12, 20162013 Kia Optima, Sxl 2.0L, L4, Gas, Asp T, VIN 6, USA *
Air Conditioning (A/C) Compressor

- replaced a/c compressor

Replaced Air Conditioning (A/C) Compressor

- Confirmed Fix - Exact Vehicle Match- Confirmed Fix - Similar Vehicle Match*- Indicates a Similar Vehicle - Not an exact match to the vehicle selected

What Fixed It ?

Please describe what was done to fix the vehicle you were working on.
Example 1: Replaced fuel pump
Example 2: Cleaned Throttle Body

If the problem you were fixing is NOT the same as the problem described in the "Customer Concern" please use the Post Fix link to share your fix.

Still need help? Click here to access the Hotline Call Request Form to schedule a call from one of our Carline Specialists.

300 characters leftPosting Guidelines

Comments may be posted publicly with your username.

Identifix Service Manual Coverage Details New Vehicle Referral Help Logout FAQ Contact Us Privacy Policy Español Français

Copyright 2001 - 2016 Identifix, Inc. All rights reserved. Use of this online service is subject to Terms of Use

Expert:  Reggie Whiddon replied 7 months ago.

here is you a test procedure for that complete with location, but its not that much to just purchase there are alot of them replaced

Customer: replied 7 months ago.
Are you saying I need to replace the compressor and evap temp sensor? Do I need to do any further diagnostics?
Expert:  Reggie Whiddon replied 7 months ago.

no just the evap temp sensor

Customer: replied 7 months ago.
Ok, I will buy one and try it. I will get back to you after I have replaced this part.
Customer: replied 7 months ago.
Is this a part I can buy at an autoparts store?
Customer: replied 7 months ago.
Where is this sensor located? I cannot find it. Can you send a picture? Thanks Reggie