How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Matt Your Own Question
Matt
Matt, Engineer
Category: Kia
Satisfied Customers: 20947
Experience:  Mechanical Engineer BEng Hons22 years experience in car engine industry, 10 years in formula 1
12772297
Type Your Kia Question Here...
Matt is online now
A new question is answered every 9 seconds

I turns over and starts second then dies i scanned it

Customer Question

I turns over and starts for a second then dies i scanned it and it was a problem with the cam sensor. So we replaced it and that didnt fix it. It is a 2002 optima lx 5speed 2.4liter dohc.
JA: Sometimes things that you think will be really complicated end up being easy to fix with a Kia. The Kia Mechanic I'm going to connect you with knows all the tricks and shortcuts. Are you hoping to fix this yourself?
Customer: Yes i am
JA: Great! What have you tried so far?
Customer: Well just what i said thats all cause the car is a friends that lives a ways away from me
JA: Is there anything else the Kia Mechanic should be aware of about your Kia?
Customer: Its only got 90000 miles on it
JA: OK. Got it. I'm sending you to a secure page on JustAnswer so you can place the $5 fully-refundable deposit now. While you're filling out that form, I'll tell the Kia Mechanic about your situation and then connect you two.
Submitted: 10 months ago.
Category: Kia
Expert:  camerontech replied 10 months ago.
hi there,do you have the original trouble code?cam
Customer: replied 10 months ago.
Cant remember the number but it was a code for the cam sensor circuit i replaced the connector cause ot was broke but the problem still is there
Expert:  camerontech replied 10 months ago.
there are too many codes that can have a cam sensor , and each one has a different diagnostic procedurei will have to opt out unfortunatly
Customer: replied 10 months ago.
I believe it was po340
Expert:  Matt replied 10 months ago.
hello a P0340 code is a fault with the 'A' circuit wiring so this is the signal wire or a fault with the signal circuit of the sensorI've seen that you've replaced the connector on the wire but have you replaced the sensor itself?and if thats OK then you need to do a continuity check between the sensor plug and the ECU plug to confirm that the wiring is OK
Expert:  Matt replied 10 months ago.
Hido you still need help?Bear in mind that the site takes a deposit from you at the beginning and this is held by the site until you rate my answer at which point the cash is split between the site and the expert. I am only paid for my work on this question if you rate my answer, using the star system at the top of the screen. Please do not forget! Thank you

Related Kia Questions