How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Kiatech Your Own Question
Kiatech, Kia Master Technician
Category: Kia
Satisfied Customers: 210
Experience:  30+ years experience,ASE certified,KIA certified Master Technician,Ford factory trained
Type Your Kia Question Here...
Kiatech is online now
A new question is answered every 9 seconds

Have 2005 Kia amanti slow trotted response And step on brake

Customer Question

Have 2005 Kia amanti slow trotted response And step on brake pops through air intake. Replaced accer. Position pedal sensor 3 new coils
Submitted: 7 months ago.
Category: Kia
Expert:  indy-tech replied 7 months ago.

Okay thank you for getting to us with your car problem but could you give us a bit more info .

Which engine .

Did you have malfunction codes that you worked from to get you to change the

APP and coils .

Give us something to calculate for you .

Rgds Greg

Customer: replied 7 months ago.
Code po123 &po222 car has no power Ideals high about 2000 pops when you step on brake eng.3.5
Expert:  indy-tech replied 7 months ago.

After you replaced the parts, did you clear codes and restest..


Expert:  indy-tech replied 7 months ago.

Did you replace the TPS on the throttle body

Customer: replied 7 months ago.
replaced tps
Expert:  indy-tech replied 7 months ago.

Okay then look and check the connection and wiring harness from the TPS to the PCM

This is now probably a wiring harness or connection issue ,check the pins on the connection

check the diagram attached on the TPS ..

Check the connector pins in the plugs .on the TPS and PCM..

If you find all good then suspect PCM malfunction . but not come across a failed PCM as of yet for this vehicle

so must be wiring ,connection ?or the new TPS is also bad .

Please remember to only rate my answer when you are 100% satisfied.

IF you feel the need to click either "Helped a little" or "I expected more",
please stop and reply to me via the CONTINUE CONVERSATION button with the issue you have.
I will be happy to continue further and do everything I can to provide you with the service you seek.

Kind regards Greg.

Related Kia Questions