How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Andrew Martin Your Own Question
Andrew Martin
Andrew Martin,
Category: Kia
Satisfied Customers: 254
Experience:  Technician at Wile Hyundai
92331225
Type Your Kia Question Here...
Andrew Martin is online now
A new question is answered every 9 seconds

2004 Kia Optima. Starts and idles but as soon as you try to

Customer Question

2004 Kia Optima. Starts and idles but as soon as you try to accelerate it dies. Code I'm getting is P0102. We have replaced: plugs and wires, Throttle Position Sensor, Cam sensor, coil pack.
JA: Tell me a bit more about what's going on so he can help you best.
Customer: 2.7 L motor (V6)
JA: Are you hoping to fix this yourself?
Customer: Yes
JA: Great! What have you tried so far?
Customer: Starts and idles but as soon as you try to accelerate it dies. Code I'm getting is P0102. We have replaced: plugs and wires, Throttle Position Sensor, Cam sensor, coil pack.
JA: Is there anything else the Kia Mechanic should be aware of about your Kia?
Customer: No. It ran fine prior to this problem
JA: I'm sending you to a secure page on JustAnswer so you can place the $5 fully refundable deposit now. While you're filling out that form, I'll tell the Kia Mechanic about your situation and connect you two.
Submitted: 1 year ago.
Category: Kia
Expert:  Andrew Martin replied 1 year ago.
P0102 is a code for the mass air flow sensor. Check to see if the air filter is dirty and if it is replace it. Then replace the mass air flow sensor. It's located on the air intake tube.
Customer: replied 1 year ago.
Replaced the Mass Airflow Sensor and air filter. Now it will stay running but is still sputtering and hesitating when accelerating.
Expert:  Andrew Martin replied 1 year ago.

Alright, try disconnecting the battery for a while and see if it gets better, could need a good reset from running bad for a while. Have you ever had the timing belt replaced?

If my answer has helped you, please help me by rating or accepting my answer. This does not cost you any more, it just allows me to be credited for my work. You can always ask follow up questions after rating or accepting. Thank you

Customer: replied 1 year ago.
We replaced it along with everything else I listed. Made sure it was in time and checked everything with the timing light.
Customer: replied 1 year ago.
We're leaving the battery unhooked tonight and will try again tomorrow after noon.
Expert:  Andrew Martin replied 1 year ago.

Ok if that does not solve it, you'll have to check fuel pressure

Customer: replied 1 year ago.
Ok. Will update again tomorrow. Thanks
Expert:  Andrew Martin replied 1 year ago.

Ok.

Customer: replied 1 year ago.
Still having the problem. Fuel pressure is fine.
Expert:  Andrew Martin replied 1 year ago.

What is the fuel pressure?