How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Kiatech Your Own Question
Kiatech
Kiatech, Kia Master Technician
Category: Kia
Satisfied Customers: 210
Experience:  30+ years experience,ASE certified,KIA certified Master Technician,Ford factory trained
32162675
Type Your Kia Question Here...
Kiatech is online now
A new question is answered every 9 seconds

WE REPLACED THE VARIABLE VALVE TIMING SENSOR ON MY 2007 KIA

Customer Question

HI,
WE REPLACED THE VARIABLE VALVE TIMING SENSOR ON MY 2007 KIA SEDONA VAN AND NOW IT WONT START. WHEN CRANKING IT LOSES POWER TO THE INJECTORS
Submitted: 8 months ago.
Category: Kia
Expert:  thomas hill replied 8 months ago.

hi my name is ***** ***** the sensor you replaced where is it located i so we are on the same page.

Customer: replied 8 months ago.
Hi Tom
The sensor is In the cylinder head.
Expert:  thomas hill replied 8 months ago.

does it look like this

Customer: replied 8 months ago.
it does
Expert:  thomas hill replied 8 months ago.

did you replace the ones under the valve cover or the ones under the intake

Expert:  thomas hill replied 8 months ago.

I'm thinking you may have forgot to plug in one of the connectors the oil control valves you replaced should not of stopped the engine from starting

Customer: replied 8 months ago.
I think it was under the valve covers I'm asking now
Customer: replied 8 months ago.
It was under the valve covers
Customer: replied 8 months ago.
They are saying they have checked it 4 times? Any other ideas?
Expert:  thomas hill replied 8 months ago.

are you getting any codes?

Customer: replied 8 months ago.
No codes
Expert:  thomas hill replied 8 months ago.

can you check fuel pressure?

Expert:  thomas hill replied 8 months ago.

this engine is good at not starting it will even start with the crank sensor unplugged it uses the cam sensors so if you have no codes and won't start then I'm thinking fuel or a fuse

Customer: replied 8 months ago.
It has power to pump and good fuel pressure I'm told but they are finding when trying to start it loses power to the injectors?
Expert:  thomas hill replied 8 months ago.

have you guys checked the fuses?

Expert:  thomas hill replied 8 months ago.

the engine is a 3.8l right?

Customer: replied 8 months ago.
Customer: replied 8 months ago.
3.8 and they said they did?
Expert:  thomas hill replied 8 months ago.

when you turn the ignition to just the on position does the check engine light light up?

Expert:  thomas hill replied 8 months ago.

and when the engine is cranking is there a light that come on that looks like a car with a key in the middle of it

Customer: replied 8 months ago.
That I will need to check hold on