How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask fix it man Your Own Question
fix it man
fix it man, Master Technician
Category: Kia
Satisfied Customers: 17198
Experience:  ASE MASTER CERTIFIED, AA DEGREE AUTO/DIESEL
1627031
Type Your Kia Question Here...
fix it man is online now
A new question is answered every 9 seconds

I changed my spark plugs on 2005 sedona and now the van wont

Customer Question

Hi i changed my spark plugs on 2005 sedona and now the van wont crank. Its turning over good but not cranking. Any thoughts??
Submitted: 12 months ago.
Category: Kia
Expert:  fix it man replied 12 months ago.

Hello, my name is***** you for the question. Can you tell me if the spark plugs were all that was changed? Was the vehicle running fine prior to changing them?

Customer: replied 12 months ago.
just plugs and wires. I have done it before with no problem. Yes it was running before. It turns over fine. I sprayed some starter fluid in it and it almost started.
Expert:  fix it man replied 12 months ago.

Thank you. It sounds like something is not hooked up correctly. Most of the time this is caused by something being hit or disconnected like the crank sensor wiring. Does the rpm gauge show a reading when cranking the engine?

Customer: replied 12 months ago.
I checked all connections. All seam to be good. The rpm gauge does not move when cranking. Should i here the fuel pump prime on this van. I here it on my other cars.
Customer: replied 12 months ago.
My obd tool says linking error
Expert:  fix it man replied 12 months ago.

Yes, you should. If there is no link I would start by checking the fuses under the hood. You may have a blown fuse.

Customer: replied 11 months ago.
The fuses are fine but some did not light up with test light(injection,o2,fuel)and a few others in the same row.
Expert:  fix it man replied 11 months ago.

Can you tell me which other ones did not. I am going to check my wiring diagrams to see if something else is occurring.

Customer: replied 11 months ago.
Injector O2(dn) O2(up) (ecu)
Customer: replied 11 months ago.
Posted by JustAnswer at customer's request) Hello. I would like to request the following Expert Service(s) from you: Live Phone Call. Let me know if you need more information, or send me the service offer(s) so we can proceed.
Expert:  fix it man replied 11 months ago.

These fuses should get power directly from the battery. Are the cables at the battery clean and tight?