How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Kiatech Your Own Question
Kiatech
Kiatech, Kia Master Technician
Category: Kia
Satisfied Customers: 210
Experience:  30+ years experience,ASE certified,KIA certified Master Technician,Ford factory trained
32162675
Type Your Kia Question Here...
Kiatech is online now
A new question is answered every 9 seconds

I'm a 30 plus year tech, seen a lot of changes, I suspect

Customer Question

Hi Dave, I'm a 30 plus year tech, seen a lot of changes, I suspect I'm fighting a programing issue but need your experienced advice to confirm. I'm trying to diagnose a code po 501 on a 08 spectra,with out abs. Vehicle in air,all codes cleared, hooked up with wireless scan tool, engine running, transmittion in drive, speedometer at 12 mph, scan tool says its at 0, input shaft sensor reading 591, third gear reading on shift selection ,output sensor reading 591 +_, the scan of 0 speed doesn't match what I'm seeing at the speedometer. I'm guessing, that the input shaft sensor and out put shaft sensors are functioning correctly and that the computer is processing the info correctly to enable the instrument cluster to consistently give accurate mileage readings. I'm lost as to why I'm getting a zero mph reading at my scan tool , but believe this to be the reason for the po 501 please advise
Submitted: 1 year ago.
Category: Kia
Expert:  Ron replied 1 year ago.

Hello and thank you for your question,

Are you sure you do not have ABS, dose the right front wheel have a speed sensor?