How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Andrew Martin Your Own Question
Andrew Martin
Andrew Martin,
Category: Kia
Satisfied Customers: 233
Experience:  Technician at Wile Hyundai
92331225
Type Your Kia Question Here...
Andrew Martin is online now
A new question is answered every 9 seconds

Just installed a oem Kia keyed ignition remote starter into

Customer Question

Hi, just installed a oem Kia keyed ignition remote starter into a 2012 Kia Sorento. All functions of the remote work properly excepted with actual remote start. Car turns on for about 5 sec then turns off. This repeats automatically for two more tries before staying off. Using the key works properly. I'm not sure what can be wrong besides maybe having to program the starter. Thank you for your help
Submitted: 9 months ago.
Category: Kia
Expert:  Andrew Martin replied 9 months ago.

Hello, is this a push button ignition or a regular key ignition?

Customer: replied 9 months ago.
Regular key
Expert:  Andrew Martin replied 9 months ago.

Alright, do you have the programming and function check paper work? If you don't I can send it to you. This is the first thing to try. Apart from that, the only thing that I can think of is that there is an issue with the brake switch causing the vehicle to think that someone is getting in the car and so the security turns it off.

Customer: replied 9 months ago.
I do have the function check paper work.
Expert:  Andrew Martin replied 9 months ago.

Ok, do the function check just to be sure nothing else is causing it. Then do the tachometer programming and see if that changes anything. If it doesn't work, look into the brake switch issue. You can get it scanned to see if there are any codes relating to the brake switch. If that is not the issue, there may be something wrong with the remote start module.

If my answer has helped you, please help me by leaving a rating or accepting my answer so I may be credited. Rating or accepting my answer does not cost you extra. It allows me to be credited for my work. Please rate or accept. You can ask follow-up questions after you rate or accept.

Expert:  Andrew Martin replied 9 months ago.

Found this today, sounds like maybe this is your issue.

Related Kia Questions