How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Edward Your Own Question
Edward
Edward, Service Technician
Category: Kia
Satisfied Customers: 2759
Experience:  I have over 20 years experience in the automotive service industry.
29534642
Type Your Kia Question Here...
Edward is online now
A new question is answered every 9 seconds

My Kia just had a rebuilt transmission.I went to put it in

Customer Question

My Kia just had a rebuilt transmission.I went to put it in reverse and it slipped and made a jolt like the gears we're
JA: Thanks. Can you give me any more details about your issue?
Customer: My gears seem like they wouldn't engage and my vehicle would go in reverse but not in drive
JA: OK got it. Last thing — Auto Mechanics generally expect a deposit of about $24 to help with your type of question (you only pay if satisfied). Now I'm going to take you to a page to place a secure deposit with JustAnswer. Don't worry, this chat is saved. After that, we will finish helping you.
Submitted: 9 months ago.
Category: Kia
Expert:  Edward replied 9 months ago.

Hello, Eddie here and I will do all I can to help. How many miles have you put on this vehicle since the transmission was rebuilt? Also, what year and model is your Kia? Thank you.

Customer: replied 9 months ago.
2009 sportage the transmission was rebuilt in December and had no more than two thousand miles put on. I had it in four wheel drive yesterday. I drove it 50 miles round trip no problems. Ran fine before I had it in four wheel drive yedterdsy
Expert:  Edward replied 9 months ago.

I understand, If it went 2000 miles, likely the axle C clips were seated into the differential like the should be, I've seen them come out before, Does it operate fine in 2wd? but not 4wd? or do you get the same symptoms in 2 or 4wd?

Customer: replied 9 months ago.
I got the same when I put it in four wheel. I put it in reverse had a jolt would go in reverse but not in drive.
Expert:  Edward replied 9 months ago.

Alright, So it's in 2wd now correct? and it only has reverse? and no forward engagement even in Low 1? is that correct?

Customer: replied 9 months ago.
I noticed on the dash the car was in drive but was showing park.I am going to have it towed tomorrow to the dealership.
Expert:  Edward replied 9 months ago.

You are still within a 12 month or 12K mile period on the rebuild correct? I think it's the linkage, because the indicator and the gear selected are not lining up, You could check that where the shifter cable meets the transmission, and make sure it has full range with someone moving the gear stick, That would be something I would check first, If that is not the culprit however, It could be something internal, in which I would stay on them and make sure it gets covered under warranty. It may not have to come out again however if it is a linkage issue. Let me know if you have any further questions. I try hard to provide 5 star service, so don't hesitate if you need ask me anything else. Thank you.