How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask fix it man Your Own Question
fix it man
fix it man, Master Technician
Category: Kia
Satisfied Customers: 17171
Experience:  ASE MASTER CERTIFIED, AA DEGREE AUTO/DIESEL
1627031
Type Your Kia Question Here...
fix it man is online now
A new question is answered every 9 seconds

My 2012 kia soul! would not start last week...it would turn

Customer Question

My 2012 kia soul! would not start last week...it would turn like it was cranking,but it would never start. Sounded like lack of gas to me, but tank had plenty. Had it towed to dealership, they said it was a bad engine and could replace for about $6000. Told them I would just have it towed back home. Truck just got here and the unhooked the car, CRANKED it and drove it into the driveway. However, when I get back into the car, I can crank it, but I cannot shift it our of P ( unless I use a screwdriver to release the interlock ), the lights on the shifter do not work and the only items on the console panel that work are the Parking brake light and whatever is beside it. I've checked all of the fuses and they seem ok. I've unhooked the battery for 30 seconds and it did not correct the issue. Any other suggestions that I could try?
Submitted: 1 year ago.
Category: Kia
Customer: replied 1 year ago.
Forgot to include that I also changed out the battery last week when it would not start. Took the battery to OReilly and they said it was bad. Car sounded the same when I tried to crank it with a new battery. After that did not work, then it was sent to dealership.
Expert:  fix it man replied 1 year ago.

Hello, my name is Bobby. I am sorry to hear about your Soul. I have seen a lot of these engines fail prematurely on this vehicle. I would perform a compression test to see if the engine has actually failed. When they started the vehicle at your house did it seem to run fine? As of now you may not be able to get it out of park because of a dead battery. You need to see if the battery has bad connections or if the ground was loosened at the body. Do you have a voltage meter to run some tests?

Customer: replied 1 year ago.
Bobby,I don't think you read the entire description. It has a new battery that I purchased last week. It now cranks fine. Just no guages ( other then the Parking Brake and Seatbelt indicator light ) and I cannot shift out of park.
Expert:  fix it man replied 1 year ago.

Thank you. So to clarify, the engine cranks and runs fine, but the vehicle will not come out of park and there are no dash gauges?

Customer: replied 1 year ago.
Correct. I can get it out of Park if I use the release switch hidden in the shifter, but the gauges ( lights nor needles ) do anything.If I can get it cranked and the gauges working, I'll take it to a different mechanic to have the compression test done.
Expert:  fix it man replied 1 year ago.

Behind the left side of the dash is a fuse box. See if the TCU fuse is blown. It is possible that they may have blown a fuse when they were checking it. Also check ECU2 fuse in the box under the hood.

Customer: replied 1 year ago.
I've already checked all fuses ( left side of dash and under hood ) both visually and with a voltmeter....all show resistance.
Customer: replied 1 year ago.
To clarify..I checked an of the fuses that are the same shape as the 10a fuses...I did not know how to check the square fuses
Expert:  fix it man replied 1 year ago.

Does the shift indicator or check engine light come on when the ignition is turned on?

Customer: replied 1 year ago.
No. It's dark here, but I could send you a pic of the control panel if you wish -- just not sure how well it would turn out.
Customer: replied 1 year ago.
If it wasn't for the 2 lights that do come on ( parking brake and seatbelt ), I'd assume the entire control assembly was bad.
Expert:  fix it man replied 1 year ago.

It sounds like an electronic ignition switch failure. Most of the time when the voltage is low in the system from a bad cable connection it will act similarly, but it sounds like the ignition. If you have a voltage meter you can test it.

Customer: replied 1 year ago.
Can you provide the steps to check it?
Expert:  fix it man replied 1 year ago.

You need to access the connection on the back of the switch. From there you will see the terminals from the wires and that is where you will test it. Make sure only the red and white wires have voltage. Then turn the ignition on. With it on all but the blue wire should have voltage. If you are missing voltage or if they are below the white and red wires then the switch is bad.

Customer: replied 1 year ago.
Ok. I won't be able to check it until tomorrow. It's too dark to see how to take out the switch. Do I just ground the voltmeter to the some random metal on the car or is the a negative lead on the back of the switch?
Expert:  fix it man replied 1 year ago.

Yes, ground the negative lead and probe with the positive lead.

Customer: replied 1 year ago.
Thanks. I'll give you the results tomorrow.
Expert:  fix it man replied 1 year ago.

Sounds good. Thank you. Have a good night and Happy New Year.