How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Cardoctor71 Your Own Question
Cardoctor71
Cardoctor71, ASE Certified Technician
Category: Kia
Satisfied Customers: 670
Experience:  ASE Master Certified Technician
36867192
Type Your Kia Question Here...
Cardoctor71 is online now
A new question is answered every 9 seconds

I have an 08 kia spectra speedometer not working bought a

Customer Question

Customer: i have an 08 kia spectra speedometer not working bought a new speed sensor same effect after i made a 1400 mile trip to cali and back to texas it started malfunctioning. changed the speed sensor same effect work in cool temp and stop as soon as the dash reached warm temp now its just plain dead. can you help. i was told it was a wiring harness malfunctions
JA: Thanks. Can you give me any more details about your issue?
Customer: all other needles on instrument cluster work except speedometer. something interrupts that specific wire
JA: OK got it. Last thing — JustAnswer charges a fee (generally around $18) to post your type of question to Kia Experts (you only pay if satisfied). There are a couple customers ahead of you. Are you willing to wait a bit?
Customer: glad to pay if you can solve this already took to a mechanic to no avail
JA: OK. Now I'm going to take you to a page to place a secure deposit with JustAnswer. Don't worry, this chat is saved. After that, we will finish helping you.
Submitted: 11 months ago.
Category: Kia
Expert:  Cardoctor71 replied 11 months ago.

Most likely the problem is an internal issue in the speedometer head, the instrument cluster will most likely have to be replaced. Please RATE my service a 3 or above, if for some reason you can not, Please ASK another question, I will continue to answer your questions, even after rating is given, until you are completely satisfied with my answers.

Customer: replied 11 months ago.
Already tried another cluster worked for a day and also died
Expert:  Cardoctor71 replied 11 months ago.

This would be normal if you failed to flash the computer to reprogram the vin # ***** the 2nd cluster, so that the computer would recognize it electronically, other wise the anti theft system will trigger and shut the vehicle down because the computer thinks the vehicle is being stolen.