How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask rpmdiag Your Own Question
rpmdiag
rpmdiag, Tech and Instructor
Category: Kia
Satisfied Customers: 6881
Experience:  Since 1975
12769047
Type Your Kia Question Here...
rpmdiag is online now
A new question is answered every 9 seconds

I have 2004 KIA Rio that I purchased with a bad fuel pump. I

Customer Question

I have 2004 KIA Rio that I purchased with a bad fuel pump. I have replaced the pump, but I am still not getting a successful start. Engine cranks and starts for a few seconds then dies out. I can keep the engine alive with starter fluid. Pressing the gas while the engine is started only causes it to die.
Submitted: 1 year ago.
Category: Kia
Customer: replied 1 year ago.
I want to add that I have replaced the fuel filter as well, and I am getting adequate fuel pressure to the engine.
Expert:  rpmdiag replied 1 year ago.

Hi, I’m Ron and I can help you.
I have been in this business since 1975 and also teach automotive repair. I am confident we can resolve your problem together. Please understand that I don't know your skill level. I can't see, smell, hear, or touch the vehicle either, so it may take a few replies to get to satisfactory results. Please be patient!
I also try to give all of the information you may need, expecting a “positive rating” in return. I will also continue assisting you after you have rated me, if necessary. If there is any reason I cannot get a positive rating, please let me know why “in advance”, so I can go another direction for you. I am sorry you’re having this problem; I’ll help you through it.

It sounds like you're losing power or ground to the fuel pump. Check that next so we can determine if this is computer related or fuel pump relay.

Thanks, Ron

Customer: replied 1 year ago.
The fuel pump runs consistently, and I have check all the requisite fuses that correlate to fuel delivery. When I turn the ignition to accessory, I hear the pump running, and on two occasions, I have been able to maintain a rough idle with the pedal pressed to the floor. Would a bad ground be consistent in the problem I am experiencing? I also have an OBD diagnostic tool available.
Expert:  rpmdiag replied 1 year ago.

If the pump stays running, then you need to check your fuel rail power to the injectors. It sounds like that's where you're losing your fuel. Try to run the vehicle on propane or carb cleaner in the intake area to ensure it really is a fueling problem.

Thanks again.

Ron

Customer: replied 1 year ago.
Fueling the vehicle from the intake does work. I will attempt to replace the injectors and see if my result is the same.
Expert:  rpmdiag replied 1 year ago.

No, don't replace the injectors yet, first use a noid light to see if they are getting power. I'm sure the injectors are ok.

Thanks again, and please don't forget to rate me and keep this link in case we still need to talk.

Ron

Related Kia Questions