How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Kiatech Your Own Question
Kiatech
Kiatech, Kia Master Technician
Category: Kia
Satisfied Customers: 210
Experience:  30+ years experience,ASE certified,KIA certified Master Technician,Ford factory trained
32162675
Type Your Kia Question Here...
Kiatech is online now
A new question is answered every 9 seconds

Kia Optima EX: kia optima DASH DOES NOT TURN ON

Customer Question

dashboard does not turn on, I push start botton twice and the dash does show any warning light, as check engine airbag, and more, just the theft light, the radio turn on,  car wont start

Submitted: 2 years ago.
Category: Kia
Expert:  Jerry replied 2 years ago.

Hello and welcome. My name is ***** ***** you for visiting the site, I will be happy to assist you today. . What year is it ? .

Customer: replied 2 years ago.

2011 kia optima, this car is smart key push start bottom , I push start botton twice we need to diagnose the car but dash does not shows , warning lights such as engine light, airbag light, abs light, even wont start

Expert:  Jerry replied 2 years ago.
I see, thanks.
.
Some did have a CAMPAIGN for the battery cables bot does it show to have battery voltage to the fuse box under the hood?
.
Customer: replied 2 years ago.

YES all cables form battery to fuse has voltage...

Expert:  Jerry replied 2 years ago.
That isn't one of the things that I have run into on one of them, but wait there may be another expert who has more. I will opt out and open it back up. Please DON’T REPLY to this post as that will lock the question back to me, someone should be along shortly, I’m sure, thanks and sorry I wasn’t able to help with it.
.
Customer: replied 2 years ago.

we found bad relay to ECU 1