How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask George H. Your Own Question
George H.
George H., ASE Certified Technician
Category: Kia
Satisfied Customers: 18386
Experience:  Hyundai Certified and 15+ years as an ASE Maser Tech
13574682
Type Your Kia Question Here...
George H. is online now
A new question is answered every 9 seconds

Kia Soul: the upper oxy sensor haness side connector was destroyed. the

Customer Question

the upper oxy sensor haness side connector was destroyed.
the wires are plnk blue green white harness side.
sensor side wht wht 2 black gray.how do they match up. i cant find a pigtail connecto anywhere or a color for the harness side
Submitted: 1 year ago.
Category: Kia
Expert:  George H. replied 1 year ago.
Hello I will help you with your question,
You have 2 whites one black and one grey correct?
Customer: replied 1 year ago.
yes what i need to know is which harness side wires connect to these harness side wires are pink blue green white
Expert:  George H. replied 1 year ago.
The white to the pink,
second white to the white
Blue to the grey
Black to the green.
Please let me know how I can help
Thank you
Customer: replied 1 year ago.
george seems to work fine taking a 100 mile test drive now good work was had to tell wht and wht 1 apart
Expert:  George H. replied 1 year ago.
The whites on the sensor are just both ends of a resistor so it does not matter which goes to the white of the vehicle harness and which to the pink.
Please let me know if you have further questions
Thank you
Customer: replied 1 year ago.
hi george the 2011 kia soul oxy snsor prolem rewire i did seems to correct proble works for about 60 miles then problem comes back I notice no problem in operation or milege any suggestion, also the tire pressue light comes on even when tp seems ok i am the second owener 68000 miles any warrenties avvaible?
Expert:  George H. replied 1 year ago.
No warranty available for this. You will need to get it diagnosed to see what is going on. Monitoring with a scantool will show if it is the sensor operation causing the code if you are getting a code for the O2 sensor. Let me know how I can help Thank you