How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Robert Your Own Question
Robert
Robert, ASE Certified Master
Category: Jeep
Satisfied Customers: 4274
Experience:  ASE Master Certified, Chrysler Certified
49095596
Type Your Jeep Question Here...
Robert is online now
A new question is answered every 9 seconds

I have a 2000 Jeep 4.0L 6cyl 4wheel drive Cherokee Classic 2

This answer was rated:

I have a 2000 Jeep 4.0L 6cyl 4wheel drive Cherokee Classic2 weeks ago my Airbag light would come up intermittently.
Now by gauges have ceased working. The CEL is lit as is the Airbag.
The Instrument panel shows “no bus” code in the odometer.The vehicle starts and runs fine but again the gauges are not working UNLESS you hit the door lock button to “open”. Then some or all of the gauges may work for a few seconds.My neighbor used his code reader and the corresponding code states the PCM is not reading the instrument panel. There was also a TBS 8-15-1999 bulletin stating that I should replace the instrument plug harness with new plug patches.I have:
Undone the negative battery cable for 10 minutes to “reset”
Pulled off the instrument panel and cleaned all connections on the back (the same ones the TBS said to replace).
Made sure the ground wire bolts were tight.I did call the dealership to see about ordering the plug patches and of course they said it would take two weeks and each one was $29.99 (need 2) and not the $8 to $11 that everyone on the various Jeep forums spoke about.So that’s where I’m at so far. . . Any ideas would be greatly appreciated.
JA: Does the light stay on, or does it blink?
Customer: no blinking
JA: What year is your Cherokee?
Customer: 2000
JA: Are you fixing your Cherokee yourself? What have you tried so far?
Customer: I have: Undone the negative battery cable for 10 minutes to “reset” Pulled off the instrument panel and cleaned all connections on the back (the same ones the TBS said to replace). Made sure the ground wire bolts were tight.
JA: Anything else you want the mechanic to know before I connect you?
Customer: Did you see the part about the TBS I wrote on?

Hello, welcome and thanks for asking your question. My name is*****'m a Certified Auto Technician with 29+ years experience. I will do my best to assist you. please keep in mind that I may need to ask questions of you before I can answer. When you reply please feel free to add as much detailed information as possible pertaining to your concern.

That tsb does not apply to the 2000 model year. See the following star case for info on a fix for the 2000 model year...

--->> Click Here to view <<---

Keep me posted and let me know if you have any additional questions...

Thank you,

Robert

Customer: replied 4 months ago.
Hi Robert -
Sorry for the delay. I did take the Ground 101 off the block, cleaned and sanded everything for a nice connection and then reinstalled it all. Unfortunately it didn't do trick. Any other ideas or suggestions?

Here is another star case to try out.... --->> Click Here to view <<---

There may be more so let me know if you find anything with this one...

Thank you,

Robert

______________________________________

If you need additional information, don't hesitate to ask, I am happy to help as long as necessary to help solve your concern. Remember, a "Positive" Rating will not close this question, You can post a reply here whenever you want, even after rating my answer! .

Thank you!

Robert

Robert and 3 other Jeep Specialists are ready to help you
Customer: replied 4 months ago.
Thanks I give it a try this weekend!

Thanks,

I'll be here for follow up questions if needed.

Thank you and thanks for using JustAnswer!

Robert