How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Chris Your Own Question
Chris, Shop Foreman
Category: Jeep
Satisfied Customers: 3137
Experience:  Jeep Certified Master Tech
Type Your Jeep Question Here...
Chris is online now
A new question is answered every 9 seconds

I have a 2001 Jeep Cherokee 4.0 / automatic. I just took off

Customer Question

Hi I have a 2001 Jeep Cherokee 4.0 / automatic.
JA: Are you fixing your Cherokee yourself? What have you tried so far?
Customer: I just took off on the thousand mile trip and the transmission began to start whining about 300 miles away I pulled over and put it in park and the noise goes away but is soon as I put it in gear whining starts, now it seems to not want to shift into third
JA: Have you heard this particular sound before?
Customer: No I have not
JA: Anything else you want the mechanic to know before I connect you?
Customer: That's really all I know other than it seems to be getting harder and harder for it to shift when I get back on the freeway after stopping for fuel
Submitted: 16 days ago.
Category: Jeep
Expert:  kalamykid replied 16 days ago.

Have you checked the fluid level?

Expert:  kalamykid replied 16 days ago.

You have to check the fluid level with the engine running, and the transmission in neutral.

Customer: replied 16 days ago.
I have, that was the first thing I checked. The level is good and yes it was running and in neutral
Expert:  kalamykid replied 16 days ago.

Does it start winning as soon as you put it into gear? Does it do it in neutral?

Customer: replied 16 days ago.
No It is not making the noise in neutral or park R and drive, last time I got off the freeway it slipped while shifting into 3rd, I pulled over and let it sit for a few min and took back off and between 2nd and 3rd it slipped and revved up then caught 3rd so I kept going until now. I've bought a filter and new fluid in hopes that it might help?
I've had it for 7-8 months and haven't done anything to the trans except check the fluid
Expert:  kalamykid replied 16 days ago.

It sounds like it is starving for fluid. A filter change may do some good. When you drop the pan, can you send me a pic of the bottom of the pan before you put the pan back on please? This way I can see what may be going on inside.

Expert:  kalamykid replied 16 days ago.

When you drop the pan, do not let all of the fluid drain out of the pan. Leave a small amount so the paticals in the pan does not get washed out.

Customer: replied 16 days ago.
Ok will do,might be in the morning so I have light
Thank you
Expert:  kalamykid replied 16 days ago.

You are very welcome. Chat with you in the morning.