How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Brad Your Own Question
Brad, Jeep Dealership Tech
Category: Jeep
Satisfied Customers: 6774
Experience:  19 Yrs Chrysler/Dodge/Jeep. ASE Master (L-1) Certified
Type Your Jeep Question Here...
Brad is online now
A new question is answered every 9 seconds

Wipers run even tho the wiper switch is off, no dash lights,

Customer Question

wipers run even tho the wiper switch is off, no dash lights, no horn, can not take out of park, no door locks, no interior lights. Will start and run, radio works, power windows work.
JA: Have you checked the fuses? The dashboard bulbs?
Customer: yes just started all at the same time
JA: What is the model/year of your Jeep?
Customer: 2008 wrangler auto 2 wd
JA: Are you fixing your Wrangler yourself? What have you tried so far?
Customer: changed out the tipm but nothing changed
JA: Anything else you want the mechanic to know before I connect you?
Customer: no
Submitted: 1 month ago.
Category: Jeep
Expert:  Dan replied 1 month ago.

Hello, my name is ***** ***** I'm here to help get your problem solved.

Customer: replied 1 month ago.
Expert:  Dan replied 1 month ago.

The totally integrated power module controls wiper motor and everything else you mentioned so it sounds like the module has failed. The replacement module will need to be reprogrammed at dealer so you are looking at around a $500 job total. Let me know if you have more questions, thanks.

Customer: replied 1 month ago.
as stated above we have already changed the tips
Customer: replied 1 month ago.
Expert:  Dan replied 1 month ago.

Sorry, I missed that part. Did you have it reprogrammed? Have you checked power/ground going to the TIPM? Thanks.

Customer: replied 1 month ago.
instructions said to reconnect battery and turn switch to on position for 12 seconds
Expert:  Dan replied 1 month ago.

Were you having EXACT same problem before installing?

Customer: replied 1 month ago.
exact same problem
Expert:  Dan replied 1 month ago.

Check for good ground on black wires going to module. Let me know, thanks.

Customer: replied 1 month ago.
Already checked all grounds I could find
Customer: replied 1 month ago.
all grounds checked
Expert:  Brad replied 1 month ago.

Good morning and welcome to JustAnswer!!

My name is ***** ***** I have worked for a Chrysler-Dodge-Jeep dealership for 19 years and I will do my best to help.

Did you connect a scantool and confirm the TIPM was bad before replacing it? If not then it's likely not the TIPM bad but rather the multifunction switch or clockspring. I would start by connecting a scantool to see exactly what codes are in all the modules. This is the proper way to diagnose and repair your issues instead of guessing and wasting money on replacing good parts.. Once you have the codes post them here so I can help you get it fixed..

Talk soon,


Related Jeep Questions