How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Chris Your Own Question
Chris
Chris, Shop Foreman
Category: Jeep
Satisfied Customers: 3271
Experience:  Jeep Certified Master Tech
12365498
Type Your Jeep Question Here...
Chris is online now
A new question is answered every 9 seconds

Jeep random misfire

Customer Question

Jeep random misfire
Submitted: 8 months ago.
Category: Jeep
Expert:  cloe0626 replied 8 months ago.

did you get the firing order correct

Customer: replied 8 months ago.
I'm not sure. How do I check it or change it?
Customer: replied 8 months ago.
No wires or distributor, already replaced plugs. It's cop
Customer: replied 8 months ago.
Just pulled code p0403
Customer: replied 8 months ago.
Can you help me?
Expert:  Dan replied 8 months ago.

Hello, my name is***** it run rough at idle and rough going down street? Thanks.

Customer: replied 8 months ago.
Sure-(###) ###-####
Customer: replied 8 months ago.
It idles rough. Havent tried to drive it
Expert:  Dan replied 8 months ago.

Does it seems to run any better while pressing on gas pedal?

Customer: replied 8 months ago.
some
Expert:  Dan replied 8 months ago.

Have you tried to disconnect EGR to see if it made a difference?

Customer: replied 8 months ago.
No
Expert:  Dan replied 8 months ago.

Try that and let me know, if no difference remove EGR to see if it is stuck open. Keep me updated, thanks.

Customer: replied 8 months ago.
Disconnected it and no change. I'll remove it
Expert:  Dan replied 8 months ago.

Ok, keep me updated. Thanks.

Customer: replied 8 months ago.
Put in a new egr, it's better but still not running 100%
Customer: replied 8 months ago.
Not pulling any codes
Expert:  david craig replied 8 months ago.

Hi Im David, try cleaning the MAF and IAC and throttle body plate. See if that helps it a bit.

Customer: replied 8 months ago.
Ok. It only runs when I push the gas
Expert:  david craig replied 8 months ago.

try the above suggestions........let me know