How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask sprinkles08 Your Own Question
sprinkles08
sprinkles08, ASE Certified Technician
Category: Jeep
Satisfied Customers: 21597
Experience:  Chrysler/Dodge/Jeep Master Certified, ASE Master and Advanced Certified, Trans and Hybrid Specialist
9825021
Type Your Jeep Question Here...
sprinkles08 is online now
A new question is answered every 9 seconds

1995 jeep grand cherokee, had tken sfter factary alarm off

Customer Question

1995 jeep grand cherokee, had tken sfter factary alarm off not sometimes car wo't start or cut offf while driving
Submitted: 3 months ago.
Category: Jeep
Expert:  Cary York replied 3 months ago.

Hi, I’m Cary and I’ll be helping you today.
Please understand that I can't smell, hear, or touch the vehicle either, so patience is appreciated. Before leaving the site make sure and leave me a rating. You can still reply to me as many times as needed, even after the rating..

Did you take the alarm system off to try and fix the no-start problem?

Customer: replied 3 months ago.
the alarm was taken off and now it starts some times and some times not. it is like i t sometimes it won't fire. i also was told it was maybe my relay fuses. it is gettting gas but not firing. Also i can be driving and it will just shut off. they checked a sensory and said it wasn't that, any ideas what it could be?????
Expert:  Cary York replied 3 months ago.

Sorry for the delay. Just got off work. Is the check engine light on? Sounds like a crankshaft sensor. But normally if it shuts off while driving it will set a code.

Customer: replied 3 months ago.
no check engine light . ir cranks and somtimees fires up but maybe 20 minutes cuts out on me. i did not have this problem until i had the alarm system removed. It' like something was not done right or wires arent grounded right. i bet it is somethin sinple but don' know what
Expert:  Cary York replied 3 months ago.

Sorry for the delay. I will have to opt out so another expect can help. Got to go to work.

Expert:  sprinkles08 replied 3 months ago.

Hello and welcome to JustAnswer!

If it's losing spark then the first thing I would suspect is a failed coil driver in the powertrain control module, but a loss of crank sensor signal is another likely cause.

The first step in diagnosing the problem is to use a scan tool or code reader to check for fault codes. Anything causing a loss of spark should set a code unless the problem is in the secondary side of the system.

Have you checked for fault codes?