How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask sprinkles08 Your Own Question
sprinkles08, ASE Certified Technician
Category: Jeep
Satisfied Customers: 21412
Experience:  Chrysler/Dodge/Jeep Master Certified, ASE Master and Advanced Certified, Trans and Hybrid Specialist
Type Your Jeep Question Here...
sprinkles08 is online now
A new question is answered every 9 seconds

03 Grand Cherokee 4.0 Turn sigs did not work, did. I

Customer Question

03 Grand Cherokee 4.0 Turn sigs did not work, flasher did. I replaced the flasher but turn sigs still don't work
JA: What are all the symptoms you've noticed (e.g. noises, leaks, flashing lights, error codes)?
Customer: No noise leaks or error codes. Just turn sigs don't work but emergency flasher does
JA: How old are the hoses? And what driving conditions do you most often encounter?
Customer: New hoses. Street, freeway, outback (least often)
JA: Are you fixing your Outback yourself? What have you tried so far?
Customer: what outback? I'm talking about my Jeep
JA: Anything else you want the mechanic to know before I connect you?
Customer: No that's enough. I just want to know what he might think is happening
Submitted: 2 months ago.
Category: Jeep
Expert:  AZTechBrian replied 2 months ago.

Hello. This is not uncommon on this vehicle. Under the dash there is a turn signal relay that is in need of replacement. You could also attempt to repair if you have a soldering iron and the ambition to do so.

Expert:  AZTechBrian replied 2 months ago.

I will find you a diagram showing the location of that relay if you'd like.

Customer: replied 2 months ago.
I've already replaced it with a new one just now. No change
Customer: replied 2 months ago.
Flashers work turn sigs do not.
Expert:  AZTechBrian replied 2 months ago.

Yes. That's exactly what happens when this relay goes bad. the hazards will work but turn signals will not. You replaced the relay in the front junction block?

Customer: replied 2 months ago.
that's what I'm trying to tell you -- relay was replaced, same symptons as previously indicated still occurring
Expert:  AZTechBrian replied 2 months ago.

Ok. ;I have seen this numerous times and it has always been that relay. Since it's not the case for you, I will open this up in hopes that someone else here knows of another issue that would cause this. Sorry about that. Someone should be along shortly.

Expert:  sprinkles08 replied 2 months ago.

Hello and welcome to JustAnswer!

Do you still need help?

Customer: replied 2 months ago.
Yeah problem still exists
Expert:  sprinkles08 replied 2 months ago.

Are you able to do electrical testing?

Customer: replied 2 months ago.
No did no further diagnostics.
Expert:  sprinkles08 replied 2 months ago.

You've checked fuses?

Customer: replied 2 months ago.
I looked at the fuse box (there are two one under the dash and one under the hood) but the owner's manual wasn't real clear which fuse governs the turn signals. Can you tell me?
Customer: replied 2 months ago.
I have an assortment of fuses so changing one immediately would be no issue. I just need to know which one ...or could it be one of many?
Expert:  sprinkles08 replied 2 months ago.

Fuse 20 in the junction block is the one in question.

Customer: replied 2 months ago.
Will check and advise.and replace if blown
Customer: replied 2 months ago.
Replaced fuse. Right blinker works left does not
Customer: replied 2 months ago.
How's that??
Customer: replied 2 months ago.
Fuse blew after about 15 mins of driving. No sigs at all now. Any other suggestions?
Expert:  sprinkles08 replied 2 months ago.

The fuse blew because there is a short to ground somewhere in the circuit. It could be anywhere between the flasher and each light. If the left side didn't work then there is a good chance the short is in the left side wiring. The first thing that will need to be done is a visual inspection of all the wiring, paying particular attention to trailer tow wiring if you have it.

Customer: replied 2 months ago.
OK we'll have my mechanic check it out. Thank you
Expert:  sprinkles08 replied 2 months ago.

You're welcome and good luck with it!

Customer: replied 2 months ago.
Your online troubleshooting was very helpful thanks again
Expert:  sprinkles08 replied 2 months ago.

You're welcome!

Related Jeep Questions