How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Brad Your Own Question
Brad, Jeep Dealership Tech
Category: Jeep
Satisfied Customers: 6740
Experience:  19 Yrs Chrysler/Dodge/Jeep. ASE Master (L-1) Certified
Type Your Jeep Question Here...
Brad is online now
A new question is answered every 9 seconds

I have a 2008 jeep liberty. Just had the radio replaced and

Customer Question

I have a 2008 jeep liberty. Just had the radio replaced and when I took it from the shop the ESP BAS light as well as the car symbol with the squiggle lines behind are on. I only have driven it 4 miles since I picked it up. Could the radio replacement and maybe some wiring error be thecause?
JA: No, I use streaming services like Pandora. Sometimes things that you think will be really complicated end up being easy to fix with a Jeep. The Jeep Mechanic I'm going to connect you with knows all the tricks and shortcuts. Are you hoping to fix this yourself?
Customer: no
JA: OK! The Jeep Mechanic will help you with the diagnostics so you are sure to get this fixed right. Is there anything else the Jeep Mechanic should be aware of about your Jeep?
Customer: no
JA: OK. Got it. I'm sending you to a secure page on JustAnswer so you can place the $5 fully-refundable deposit now. While you're filling out that form, I'll tell the Jeep Mechanic about your situation and then connect you two.
Submitted: 5 months ago.
Category: Jeep
Expert:  Brad replied 5 months ago.
Good morning and welcome to JustAnswer!!My name is ***** ***** I have worked for a Chrysler-Dodge-Jeep dealership for 18 years and I will do my best to help. Your issues most likely have nothing to do with the radio replacement, and for your model I would highly suspect a bad wheel speed sensor which is what we see most.. But to properly diagnose and correct your issues you will need a scantool to see what codes it has, and also you will need a scantool to erase them as well.. Once you know what codes it has then you will be able to repair it... If you need anymore assistance feel free to reply and don't forget the RATING before leaving the site!!Have a great day,Brad