How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask roybelding Your Own Question
roybelding
roybelding, ASE Certified Technician
Category: Jeep
Satisfied Customers: 4656
Experience:  My knowledge of Jeeps from the early 60's till present. Love to help people with there issues.
3506196
Type Your Jeep Question Here...
roybelding is online now
A new question is answered every 9 seconds

Jeep Grand Cherokee: 1994 Jeep Grand Cherokee V6 4x4 No spark

Customer Question

1994 Jeep Grand Cherokee V6 4x4
No spark from coil pack
Replaced coil pack and still has issue
Replaced the following:
Crank position sensor (twice) one from NAPA and another from dealer
camshaft position sensor
Distributor internal sensor
coil pack (again)
ECM (twice)
and still nothing........... I am getting frustrated
When I crank the truck over I am getting 4v from both the coil wire and injectors
Grounds are all good too. Not sure what else I can do. Distributor rotor spins while cranking as well.
Submitted: 7 months ago.
Category: Jeep
Expert:  roybelding replied 7 months ago.
good afternoon my name is ***** ***** I will assist I attached a diagram for you to view. can you verify the 8 volt signal with the key on engine off to the crank and cam sensors??? Roy
Customer: replied 7 months ago.
Wires are a bit faded for colors but I verified 7.6V on both sensors with key On.
Camshaft Sensor (in distributor)
- yellow/black wire 7.6V
- green/black 5.05V
- ground wireCrankshft sensor
- yellow/black 7.6V
- green/red 5.0V
- ground wire
Expert:  roybelding replied 7 months ago.
ok, thanks, ***** ***** the battery voltage??? I am concerned about only 7.6 volts
Customer: replied 7 months ago.
Battery currently at 11.6V
I was just trying a few things earlier today and trying to turn it over but the battery is new. I replaced it during the winter when I replaced all 4 tires (only reason I am trying to fix it). I have the charger on it now getting it some juice.
Expert:  roybelding replied 7 months ago.
ok, first charge the battery. it needs to be 12.6 volts. at 11.6 it is no good Roy
Customer: replied 7 months ago.
RGR. Anything else I can try in the mean time?
I also traced the wires from the cam sensor, coil pack and crank sensor through the wiring harness and to the computer. No breaks in any of them as they all checked out.
Expert:  roybelding replied 7 months ago.
nope, lets get the battery up to life and re test Roy
Customer: replied 7 months ago.
Does the 8 volts come from the ECM signal or ignition switch? Just curious as to where this leads to next.
I have the charger set 12V 15 amps for 10 min. Should be good shortly.
Expert:  roybelding replied 7 months ago.
ok, if you viewed the schematic, it originates from the pcm. the signal voltage returns to the pcm as well. grounds are external Roy
Customer: replied 7 months ago.
Meant PCM signal. So key turns on, ignition switch sends power to PCM and then to the crank and cam sensors. Makes sense. I was thinking it the PCM is not sending the 8 volts, is that going back to the ignition switch? I also replaced the auto shutdown relay previous I forgot to mention.
Expert:  roybelding replied 7 months ago.
no, if the ignition switch was bad, there would be no power to the pcm and would have a dead pcm. no check engine light and no reference voltage. Roy
Customer: replied 7 months ago.
Ok. Lets say that I don't get the 8 volts after fully charged to either the Crankshaft or Camshaft sensor, what would be next?
Also, I do not have the windshield washer reservoir or sensor plugged in. It was in the way when I was changing the computer. Shouldn't have any impact on what we are doing though.
Expert:  roybelding replied 7 months ago.
no, no impact. if they reference voltage is low, you have a check engine light with key on and you can read codes, then you have a failed pcm Roy
Customer: replied 7 months ago.
Ok. Just checked the voltages.
Battery: 12.51V
Key On and the check engine light does come on and then goes off:
Crankshaft Sensor: 7.42V and 5V
Camshaft Sensor: 7.42V and 5VThinking its a failed PCM? I just replaced it for the second time.
When this initially happened I ordered it and it came pre programmed from autozone. I ran through the checks and when I was getting 4V at the coil and injectors I figured I needed to replace it again. Just got the new one and installed it prior to this post. Autozone is going to be ticked.
Expert:  roybelding replied 7 months ago.
I never trust there pre programmed units. you cannot do it off car. it must be done on the car.
Customer: replied 7 months ago.
So bad PCM? How would I program it without taking it to the dealer?
Expert:  roybelding replied 7 months ago.
you cannot unless you have a communicator, laptop and the factory software from chrysler. it would cost you a couple thousand for that. it is cheaper for the dealer to do it for 150. Roy
Customer: replied 7 months ago.
Ok so I had 7.5V now at the Cam and Crank.
Battery: 12.51V
Coil: 11.7VWhen I cranked:
CAM: 7.5V
Cam: 7.5
Coil: 10.5Failed PCM is what you are thinking?
Expert:  roybelding replied 7 months ago.
are you sure 10.5 at the coil???
Customer: replied 7 months ago.
That is correct. When the key is off, I had 0V at the coil. Key on, 11.7V.
When I was cranking, coil went to 10.5. Truck still wouldn't start.
Also, I checked the Cam and Crank again and there was no change. Still at the 7.5V.
Battery is at 12.45V and I put the charger back on. Previous checks, only 4V at the coil.
Not sure what changed. Even if I ignore previous checks, right now I have the following:
Battery- 12.45V
Coil Cranking- 10.5; Not cranking 11.7
Cam Cranking-7.5; Not cranking- 7.5
Crank sensor cranking- 7.5; not cranking-7.5
Expert:  roybelding replied 7 months ago.
ok, hold on. I need these voltages at rest. not cranking??? why are doing it cranking??? Roy
Customer: replied 7 months ago.
At rest (not cranking):
Coil-11.7
Cam-7.5
Crank-7.5
Expert:  roybelding replied 7 months ago.
ok, thanks, ***** ***** me there. same results. I dont like the voltages at all.
Customer: replied 7 months ago.
Ok. I just checked again and same results. I am going to try and get a replacement PCM and call the dealership. They won't be available until Monday. How do I handle the rating for your service? Do I leave it open until Monday? I appreciate all of your help.
Expert:  roybelding replied 7 months ago.
you can rate me anytime and it still stay open and locked to me. the question will time out over time. when you rate it stays open as long as you like Roy
Customer: replied 7 months ago.
Awesome. If you don't mind, I will wait until Monday when I get the replacement or the details from dealership.
Thanks again,
Mark
Expert:  roybelding replied 7 months ago.
ok
Expert:  roybelding replied 7 months ago.
please dont forget to rate me as it is the only way I get paid for my efforts Roy
Expert:  roybelding replied 7 months ago.
please dont forget to rate me as it is the only way I get paid for my efforts Roy