How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Vladgmru Your Own Question
Vladgmru, Automotive Electrician
Category: Jeep
Satisfied Customers: 2637
Experience:  I've been working with American made cars since 1992.
Type Your Jeep Question Here...
Vladgmru is online now
A new question is answered every 9 seconds

My commander is listed as a 5speed,so I assume it has the NAG1.

Customer Question

My commander is listed as a 5speed,so I assume it has the NAG1. It is having symptoms related to a neutral safety switch failure. However I cannot locate the park/neutral contact.I am trying to determine if it is internal or external to the transmission.
JA: Good to know. The mechanics have tons of experience dealing with this sort of thing. How old is your transmission?
Customer: 9 years
JA: Ok. We'll get you to one of the go-to transmission guys. Other than the problems you mentioned, how has the car been running?
Customer: No other issues
JA: Noted. IÂ’ll pass this info along to the mechanic so that he can get you a quick fix. Are you hoping to fix this yourself?
Customer: yes
JA: Great! What have you tried so far?
Customer: changed the starter. tried to locate a neutral safety switch
JA: Anything else I can tell the Jeep Mechanic before I connect you two?
Customer: 2007 jeep commander 5.7 hemi overland
JA: I'm sending you to a secure page on JustAnswer so you can place the $5 fully refundable deposit now. While you're filling out that form, I'll tell the Jeep Mechanic about your situation and connect you two.
Submitted: 6 months ago.
Category: Jeep
Expert:  Vladgmru replied 6 months ago.
Hello and welcome to JustAnswer.My name is ***** ***** was only used on Commanders equipped with 3.0L diesel engines ( export market) .Since your Commander has a5.& hemi engine, it must have a 545RFE transmission.The 545RFE transmission uses a Transmission Range sensor that is the part of the solenoid module that is mounted to the top of the valve body inside the transmission.If you have a no crank condition and you believe it is caused by faulty park/neutral input signal, then you can just easily check that.There is a Yellow/Dark Blue wire (TRS T41 sense= Park/ neutral signal to the Powertrain Control Module) that should have Ground only In Park and Neutral.The wire connects the Transmission Range sensor to the PCM, so you will need to check it at the PCM connector C4 Terminal #27. If you have ground in Park and neutral and nothing in other gears, then the TRS works fine and you need to check other things.Hope that helps.Please do not forget to rate my answer positive if you feel it answers your question .Thanks,Vlad
Expert:  Vladgmru replied 6 months ago.
Hi,I am just checking if my answer has helped you in anyway.Please rate my answer or reply back if you need further assistance.Thanks

Related Jeep Questions