How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Dan Your Own Question
Dan
Dan, Technician
Category: Jeep
Satisfied Customers: 23692
Experience:  Independent Shop Experience, 2 Year Automotive Diploma, & Access to Information Database
17871496
Type Your Jeep Question Here...
Dan is online now
A new question is answered every 9 seconds

I'm a heavy equipment mechanic helping a friend on s (1993

Customer Question

I'm a heavy equipment mechanic helping a friend on his (1993 jeep grand Cherokee Laredo with V8) the vehicle has had electrical problems since he bought it 5 years ago. the engine computer was replaced 2 years ago and again 1 month ago along with the throttle positioning sensor. I looked at the vehicle for the first time today it will start up ok but if you put any electrical load on it the engine starts to run rough until you put such a load on it the engine dies with a fully charged battery I ran temporary ground cables to the engine and body and the problem went away even after I pulled temp. ground cables off have no idea why just a coincident or motor hit a certain temp. I have no clue
Submitted: 1 year ago.
Category: Jeep
Expert:  Dan replied 1 year ago.

Hello, my name is***** the temporary grounds helped that would mean you have a ground problem You will need to clean battery cable grounds and any other grounds you see. If problem still exists then run new additional grounds. Let me know how it goes or if you have more questions, thanks.