How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Chris Your Own Question
Chris
Chris, Shop Foreman
Category: Jeep
Satisfied Customers: 3204
Experience:  Jeep Certified Master Tech
12365498
Type Your Jeep Question Here...
Chris is online now
A new question is answered every 9 seconds

2000 Grand Cherokee Laredo. No parking lights work

Customer Question

2000 Grand Cherokee Laredo. No parking lights work whatsoever. Checked fuse #6 under column... looked good. Please help.
Submitted: 1 year ago.
Category: Jeep
Expert:  Brad replied 1 year ago.

Good evening and welcome to JustAnswer!!

It shows you have a 2000 Grand Cherokee with a 5.7.. Something's not right because we didn't have the HEMI in the WJ for 2000.. Is the year model or engine size wrong? Or I could get the last 8 digits of your VIN so I could grab a wiring diagram to see what's going on...

Talk soon,

Brad

Customer: replied 1 year ago.
Sorry.... TYPO. 4.7L V8 and last four VIN 0344
Expert:  Brad replied 1 year ago.

Thanks for the reply!!

I attached the wiring diagram.. If fuse 6 is good can you check it and verify it has 12v? Then remove the park relay and tell me if pins 30 and 86 have 12v and then clip the test light to positive battery and probe pin 85 and tell me if it lights up when the parking lights are on..

Talk soon,

Brad

Customer: replied 1 year ago.
I am not sure which is the park relay... most of them are labelled JB Power. Relay block #3 says JB Power/Lamps. There was a spare 50A relay in the cover. I replaced #3 and tried the parking lights... still inoperative. My voltmeter is out of battery since I have not used it in a while. With the 50A spare... can I try another location?
Expert:  Brad replied 1 year ago.

Sorry about that!!

I attached a picture of the location for you....

Let me know what you find,

Brad

Expert:  Brad replied 1 year ago.

Picture

Customer: replied 1 year ago.
My block looks nothing like the pic. It is narrow and skinny next to the battery.......
Expert:  Brad replied 1 year ago.

OOhh we are talking about the fuse box inside..

Customer: replied 1 year ago.
Inside block under column looks nothing like the pic??? Am I missing something?
Expert:  Brad replied 1 year ago.

If your vehicle is a 2000 WJ Grand Cherokee then your junction block looks like the picture I attached.... If it does the park relay is behind it.. But before you do that can you check fuse 6 in the interior fuse panel(Junction Box) and let me know if it's good... Also it might be a good idea to check all them inside..

Talk soon,

Brad

Customer: replied 1 year ago.
I dont know what a WJ is??? It is a 2000 Jeep Grand Cherokee Laredo. I already told you I checked #6.... scroll to beginining of thread. It is good.
Expert:  Brad replied 1 year ago.

Yes but I wasn't sure if you was checking #6 under the hood... And WJ is your body style of Jeep.. If #6 has 12v on both sides then the issue is the BCM is not telling the park lamp relay to turn on.. Are the parking lights the only thing that isn't working on the front and the rear lights? Do the turn signals and headlights work?

Customer: replied 1 year ago.
all lights work except none of the parking lights.... both front and rear.
Customer: replied 1 year ago.
Getting late.... it has been dark now for hours. Cant get batteries till tomorrow. Continue tomorrow?
Expert:  Brad replied 1 year ago.

Sorry for the delay!!

I when you get some batteries can you see if there is 12v across fuse 6.. Also you could check the relay and see if there is a ground signal on 85 or test the multifunction switch to see if it's telling the BCM to turn the parking lights on..

Keep me posted,

Brad