How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Brad Your Own Question
Brad
Brad, Jeep Dealership Tech
Category: Jeep
Satisfied Customers: 6955
Experience:  19 Yrs Chrysler/Dodge/Jeep. ASE Master (L-1) Certified
10114124
Type Your Jeep Question Here...
Brad is online now
A new question is answered every 9 seconds

I have exactly the same problem as MikeB85 is answering Jeep

Customer Question

I have exactly the same problem as MikeB85 is answering
Jeep liberty 3.7L v6 stalls after running 10 to 15 min. Codes P0320 and P0725. Replaced Crank sensor no difference.
Did you solve his problem?
Submitted: 1 year ago.
Category: Jeep
Expert:  Brad replied 1 year ago.

Good evening and welcome to JustAnswer!!!

I'm not sure what year your Liberty is but if it's an older one then there is a bulletin on the issue your experiencing.. If you have a labscope then follow this:

Case Number912370070

Vehicle IssueMIL on P0725 : 18 : ENGINE SPEED SENSOR CIRCUIT,and or P1391 : 9D : INTERMITTENT LOSS OF CMP OR CKP:CKP circuit.;If after performing powertrain test there is no problem found.

System or ComponentDTC / Error Message;Yes - Intermittent

RecommendationUsing a LAB scope check both CAM and CKP sensor signals, Load or voltage test the Both circuits if all good try good CKP sensor.

Modification Date08/07/03 1:18 PM

Did you use a OEM crankshaft sensor?

Related Jeep Questions