How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask sprinkles08 Your Own Question
sprinkles08
sprinkles08, ASE Certified Technician
Category: Jeep
Satisfied Customers: 21604
Experience:  Chrysler/Dodge/Jeep Master Certified, ASE Master and Advanced Certified, Trans and Hybrid Specialist
9825021
Type Your Jeep Question Here...
sprinkles08 is online now
A new question is answered every 9 seconds

I have an 04 grand Cherokee im getting three codes p0136

Customer Question

hey tim i have an 04 grand Cherokee im getting three codes p0136 p1495 p1499 iv seen a few post with the same problems i changed the 02 sensor the asd relay is clicking none stop i put a timer on it wen u first start it runs fine then after 1 min 33 seconds exactly every time it starts running rough an the same three codes pop up again wtf is going on
Submitted: 1 year ago.
Category: Jeep
Expert:  sprinkles08 replied 1 year ago.

Hello and welcome to JustAnswer!

You may have a handful of things going on. Your mention of the ASD relay clicking leads me to believe the powertrain control module may be failing or losing a power feed. A chattering ASD relay is a common symptom of a PCM that is partially awake. An internal failure is usually the cause of something like this, but a poor power or ground to the PCM will cause it also. A poor power or ground wouldn't be time dependent though.

Does the engine die? If so do the fuel gauge and voltmeter drop out at that time?

Customer: replied 1 year ago.
No everything stays the same if I clear the codes first the check engine light will come on that's it
Customer: replied 1 year ago.
I jus started it after sitting all night an it took about five mins to start acting up so once it reaches temp it takes the min 33 seconds after shutting it off an restarting now when I pull #16 fuse the clicking gets a little bit quieter. Before this started happening wen I pulled up to a stop sign or light the oil light would come on till I hit the gas it would go away that don't happen anymore
Customer: replied 1 year ago.
It won't die it will jus spit an sputter wen u give it gas, if u punch it it will sputter then take off right to rev limit
Expert:  sprinkles08 replied 1 year ago.

What specifically are you hearing with the ASD relay and when?

Customer: replied 1 year ago.
The asd relay clicks loud an fast sounds jus like a lifter at the same pace as the motor idling could the oil pressure sensor or temp sensor cause an issue if it's faulty
Expert:  sprinkles08 replied 1 year ago.

You're positive you're not hearing the purge solenoid on the left inner fender?

Customer: replied 1 year ago.
No I'm sure it's #38 asd I can feel it clicking. What is the BSI fuse #21 on the inner box if I pull that while it's running like shit it runs like it's supposed to
Expert:  sprinkles08 replied 1 year ago.

I'll get back to you as quickly as I can!

Expert:  sprinkles08 replied 1 year ago.

That fuse powers the purge solenoid, a/c compressor relay, and the BTSI solenoid in the shifter.

If you unplug the purge solenoid does it run ok?

Customer: replied 1 year ago.
The purge solenoid is on the fender driver side? If so yes wen I unpl it while it's running it will smooth out an run fine I had a used one from a 01 I have an it still runs rough as soon as I plug it in an it won't restart with it unplugged
Expert:  sprinkles08 replied 1 year ago.

If you remove the purge vacuum hose from the intake, cap the port and then run it is the problem gone?