How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask sprinkles08 Your Own Question
sprinkles08
sprinkles08, ASE Certified Technician
Category: Jeep
Satisfied Customers: 21602
Experience:  Chrysler/Dodge/Jeep Master Certified, ASE Master and Advanced Certified, Trans and Hybrid Specialist
9825021
Type Your Jeep Question Here...
sprinkles08 is online now
A new question is answered every 9 seconds

Got a 97 wrangler 4cyl, no spark, no injector pulse, checked

Customer Question

Got a 97 wrangler 4cyl, no spark, no injector pulse, checked and replaced crank sensor, ignition switch etc. Ecm just for giggles, asd relay good, what's left, I checked harness no rubbing or exposed wires
Submitted: 1 year ago.
Category: Jeep
Expert:  sprinkles08 replied 1 year ago.
Hello and welcome to JustAnswer!
If you have no spark or injector pulse but the PCM is awake then the most likely cause would be the cam sensor, which is in the distributor. The PCM has to see the cam and crank signal present and in sync with each other before you'll have a coil or injector drivers.
The first step in diagnosing the problem is checking for fault codes. Do you know if the PCM has communication and if so are any fault codes setting?
Customer: replied 1 year ago.
No communication
Customer: replied 1 year ago.
There is no power to coil, or distributor with key on, fuel from pump to throttle body, fills crankcase if I let it, solus says weak communication. I've checked asd set up, new distributor etc, is there a wire for kill in or under dash?
Expert:  sprinkles08 replied 1 year ago.
The fuel pump is running by itself as well as one or more injectors are stuck on?
Customer: replied 1 year ago.
Key on the pump primes, when you crank it, motor turns over, inj no pulse, fuel to throttle body dumps into motor, the whole system is shit down almost like anti theft or asd
Expert:  sprinkles08 replied 1 year ago.
Does the pump run constantly when the key is turned on?
Customer: replied 1 year ago.
No only when cranking
Expert:  sprinkles08 replied 1 year ago.
Are the symptoms exactly the same as with the first PCM?
Were the PCM powers and grounds load tested?
Customer: replied 1 year ago.
Yes like I said its like its shut down
Expert:  sprinkles08 replied 1 year ago.
Were the PCM powers and grounds load tested?
Customer: replied 1 year ago.
Yes, we have traced, tracked and tested everything
Expert:  sprinkles08 replied 1 year ago.
Have you ensured there is no voltage on the sensor ground circuit, the 5v reference circuits aren't shorted to ground?
Customer: replied 1 year ago.
Where is that on the schematics? Hhmm did I miss a step
Expert:  sprinkles08 replied 1 year ago.
The sensor ground circuit is black/light blue and goes to all sensors.
The MAP sensor, TPS, cam and crank sensor all receive 5v reference on the orange wire, the vehicle speed sensor on the violet/orange.
Customer: replied 1 year ago.
I'll check tomorrow
Expert:  sprinkles08 replied 1 year ago.
Ok.

Related Jeep Questions