How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Brad Your Own Question
Brad
Brad, Jeep Dealership Tech
Category: Jeep
Satisfied Customers: 6974
Experience:  19 Yrs Chrysler/Dodge/Jeep. ASE Master (L-1) Certified
10114124
Type Your Jeep Question Here...
Brad is online now
A new question is answered every 9 seconds

Grand cherokee: Hey Donny, It s getting late here in Ga and

Customer Question

99 Grand Cherokee, 4.0 auto..Good Morning, I have front blinkers, but rapid blink, no tail turn signals. I have tail lights but lose 1 when I hit the brakes w/ lights turned on. only 1 brake light w/ lights on..both when lights off..bulbs look good and I have an ohmmeter.(but no helper on the moment to press brakes) I have a reading of almost 9 when the right blinker is on, and barely 1 on the drivers side. (turn signal relay maybe?) Also, there is a turn signal sound coming from black box under dash(goes off and on at random when the blinkers are not being used)). I'm thinking this may be the relay. The 3rd brake is not working at all..also the air is stuck on the defrost vents, previous owner bypassed heater at firewall and cruise stopped working but green cruise light comes on when engaged(stays on but no cruise)...plz advise..thanks, charles

Submitted: 1 year ago.
Category: Jeep
Expert:  Pete replied 1 year ago.
My name is ***** ***** I am a professional here at Just Answer. I noticed that your question was not getting a response and thought I would see if you still need help with this.I apologize for the delay and I hope I can still assist you with this here.
From what you have described here with the lights this may be due to a fault with the multifunction switch itself.I have seen this switch fail before in the past and had to replace it.I would have the signals tested to and from it to see if this is the cause here.This may also be why the cruise control is not working as well.Check for any shorted wiring at the bulb socket that is scorched and repair as needed if a fault is found.
As for the heater system the heater is bypassed most likely due to a heater core leak in the heater box.I have seen these leak before and they require replacement.
If you only get air from defrost most likely one of the actuators on the heater box has failed needing replaced.This can be common.
Thanks Pete
Customer: replied 1 year ago.

Hey Pete, Thanks for the reply..I have tested the bulb sockets since my post..I don't have either rear turn signal(nor do I have rear hazard lights), however,when the blinkers are engaged(and ohmmeter in hand) I have an almost 9V current on 1 socket and almost 1V(MAX) on the other..of course they fluctuate as I imagine that's due to the blinker 'pulse'(or is that feasible?) Seeing as I posted this last night at 9pm I had opportunities to Google and came across a lot of 'Flasher Relay" problems on the web, in the 99-04 models..could this be the culprit or is this the 'Multi-Function Switch" you are referring to?

Expert:  Pete replied 1 year ago.
The combination flasher relay is a common component to fail on this model here and will cause electrical issues like this.It is located under the drivers side of the dash as seen in the link below.In some cases you can tap on it and if the lights operate differently then or quit or start working then this relay needs replaced.This is a common component for this fault here as well.
https://www.dropbox.com/s/ap3m16olphq6bl8/comb-05-05.gif?dl=0
Thanks Pete
Customer: replied 1 year ago.

I have brake lights, when the lights are off, but I lose the passengers side taillights andpassenger brake light when brakes applied. Would this same unit effect that as well? 3rd brake light, upper hatch, never comes on, bulb is fine(everywhere on vehicle) but havent tested 3rd brake light socket, as i don't have an assistant right now..

Expert:  Pete replied 1 year ago.
Have you had any wiring work done recently or any collisions or accidents at all?
Customer: replied 1 year ago.

nah, just got it Apr 18..however, my cruise control worked then and I think most lights worked but I never really checked the 3rd light or hazards in the beginning...

Expert:  Pete replied 1 year ago.
The lighting issue can be caused by this combination flasher itself.It is a common component to fail and may be worth installing a replacement to see if it corrects this here.
As for the cruise control this may resolve itself once the lights are operating properly as some models if any of the brake lights are acting up this can disable the cruise control as well.
Thanks Pete
Customer: replied 1 year ago.

Very interesting, I will not be able to check on the application of this info due to being wrapped up now..I posted this at 9pm last night hoping to have a response this a.m. so I could try whatever ideas by noon...It's not your fault for the delay, I know..you answered pretty quick once I updated the level of urgency..I had sent the original post to strictly 'Jeep Techs' but as you know, nobody replied until now..do u have a lot of Jeep experience? I've had 2 cherokee sports, but its been 15 yrs..I got another one because I 'can' work on them but they do have their share of issues...

Expert:  Pete replied 1 year ago.
I have worked on several of these before but not as much as the factory technicians.I saw no one had posted to your question so I thought I would see if I could help in any way.I do know the relay is common to fail so I would start with this and see if it resolves the issue here.
Thanks Pete
Customer: replied 1 year ago.

I understand and I appreciate it..I'm fairly confident I will need to have an open line of questioning on this issue and don't want to waste your time unnecessarily..I can't try the idea until tomorrow, earliest..I have no problem rating your service as excellent but I also don't want to get charged until I have solved this issue(s)...your advice?

Expert:  Pete replied 1 year ago.
You can leave this as it is here if you like and just continue back here when your ready.The choice is up to you.Either way we can continue as needed.
Thanks Pete
Expert:  Pete replied 1 year ago.
Hi,
I am following up with you to see if you still needed help with your question you had asked.If my help didn't satisfy your question please let me know so we can continue.
Thanks Pete
Customer: replied 1 year ago.

Hi Pete, I was just leaving the conversation where we left it, as you suggested. I couldn't check out the ideas today, got swamped but I do intend to try tomorrow. Should I close this out now and pick up tomorrow when I get a chance to try the flasher/multi function relay repair? Or just leave it open until then? thanks man...

Expert:  Pete replied 1 year ago.
You can leave this open until your ready if you like.
Customer: replied 1 year ago.

Hey Pete, Sorry for the delay, Life and school got me swamped..anyway, I replaced the MF/Flasher relay and still have multiple issues...I was charged for the service by Justanswer, which is ok, but I need to get this resolved..No offense to you, as I'm sure you're a killer mechanic, but I May need a Jeep tech on this one...plz advise as I need to get this fixed, no tail lights, Omega Alarm Module clicks like blinker is on, but it's not..right blinkers work, no left blinkers, or flashers..however, 3 park lights flash when alarm set aside from the drivers rear..all other lights work including 3 brake lights and interior/dash,hood, etc..thanks, charles(***-***-****, texts are OK and free)

Expert:  Pete replied 1 year ago.
No problem.
I will open your question up for others here to see if anyone here can assist further on this.I hope you can get this resolved with ease.
Thanks Pete
Customer: replied 1 year ago.

nobody has gotten back to me Pete..any ideas/direction? thanks..charles

Expert:  Brad replied 1 year ago.
Welcome to JustAnswer!!!

My name is ***** ***** I'm a 16 yr Dodge-Chrysler-Jeep dealership technician that will be helping you today. NOTE: The deposit you placed will not credit me unless you rate me positive, and feel free to reply to me as many times as needed even after the rating.

Have you swapped the rear taillights to see if you have a bad taillight assy?

Brad
Customer: replied 1 year ago.

Hey Brad, Yeah, Updated status as of now(1:40EDT, 5-29) The clusters are fine, and I have a new Flasher relay. I have all lights, Brakes(all 3), tail lights(both), right side blinkers front and back, headlights, etc. The only lights not working are the left blinkers and hazards. However, all 4 corners flash when alarm is set or disarmed. Again, it has the OmegaA1000E alarm system. The module under the dash clicks like a blinker is on, but nothing is engaged. It starts and stops by itself, usually lasting about 15-30 seconds. That's where I am right now. (not sure if this matters but I also lost my cruise and air duct adjustment, stuck on defrost ducts now)...Just a heads up. I opened this conversation looking for a Jeep Tech, Donny never responded and Pete picked it up graciously. I just felt I needed to get someone that deals with Jeeps, as They can be quirky. This is my 3rd Cherokee(93,96 Sport) and now this 99 GC Laredo. I was charged for the service already and am looking for a resolution without paying more right now. I don't know how it works on your end at this point but that's the backstory. Thanks, ***** ***** you soon, Charles

Expert:  Brad replied 1 year ago.
Charles,

So the left blinker on the front and rear isn't working? But they do flash when you set the alarm?

Brad
Customer: replied 1 year ago.

Yes...they flash when alarm sets and is disarmed..no blinkers on drivers side and no hazards period, nowhere on the rig