How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Richard Your Own Question
Richard
Richard, Jaguar Technician
Category: Jaguar
Satisfied Customers: 15454
Experience:  12 years at a Ford/Lincoln Mercury and Jaguar dealer as technician and shop foreman.
10437779
Type Your Jaguar Question Here...
Richard is online now
A new question is answered every 9 seconds

Radio and media center stops working randomly. Stock, 2012

Customer Question

Radio and media center stops working randomly.
JA: Is this an aftermarket stereo, or did it come with the car?
Customer: Stock
JA: What is the model/year of your Jaguar?
Customer: 2012 Jaguar XF 5.0
JA: Are you fixing your XF yourself? What have you tried so far?
Customer: I've tried reading through forums, i just crossed one of Richards answers when he stated it may be the amplifier. Is it possible to find out if that worked for the previous customer ?
JA: Anything else you want the mechanic to know before I connect you?
Customer: No
Submitted: 3 months ago.
Category: Jaguar
Expert:  Richard replied 3 months ago.
Is the screen completely blank or it is stuck in the logo screen? Does this happen right after starting?
Customer: replied 3 months ago.
The screen is completely normal, what doesn't work is the media center, the radio tab turns light greyish and becomes unavailable to click. When i go into reverse sometimes it gets stuck on the reverse screen and no sound is produced such as the back up beeping noise.
Expert:  Richard replied 3 months ago.

Sorry for the delay. Yes if the audio/video button is greyed out then it could be one of the modules on the fiber optic network. It very well could be the amplifier. First check fuse #5 and #21 in the rear fuse panel in the trunk. Let me know.

Customer: replied 3 months ago.
I've checked the fuses and they were working fine, and still replaced them with new fuses just for safe measures. However you mentioned a #21 fuse, i did not see this fuse. There are #5, #10 , #15, #20 and #25. I also ordered a replacement amplifier on ebay to see if this would solve the issue. Plugged in the new amplifier and still same result ( get audio randomly). I read on the jaguarforums blog of someone having this similar issue and getting their radio audio module flashed. Would you reccomend buying a replacement on ebay such as - http://www.ebay.com/itm/10-11-12-JAGUAR-XF-XFR-HD-RADIO-AUDIO-CONTROL-MODULE-IN-TRUNK-7W93-19C034-AE-/172159395163?hash=item28157fe55b:g:nBQAAOSwZ8ZXBZTT&vxp=mtr and trying that out ?
Expert:  Richard replied 3 months ago.

That part is not compatible with your vehicle. Your vehicle has the newer style tuner so it is built into the audio unit in the dash. We may have a problem with one of the modules under the seat as sometimes water can leak into the vehicle and collect under the driver seat. The satalitte radio module is under the driver seat on the driver floor. The seat will need to be removed to check this.

Customer: replied 3 months ago.
Do you advise buying a replacement to swap it ? What would be a more efficient method of checking its functionality ?
Expert:  Richard replied 2 months ago.

I recommend we check the amplifier in the trunk to make sure all the connections are clean and secure. PLease double check those fuses and if you have a digital multimeter we can perform some tests. We are limited since we do not have all the diagnostic equipment to properly test the system.