How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Richard Your Own Question
Richard
Richard, Jaguar Technician
Category: Jaguar
Satisfied Customers: 15438
Experience:  12 years at a Ford/Lincoln Mercury and Jaguar dealer as technician and shop foreman.
10437779
Type Your Jaguar Question Here...
Richard is online now
A new question is answered every 9 seconds

2010 XF has no Digital display and climate controls are not

Customer Question

2010 XF has no Digital display and climate controls are not powering on
JA: Are you fixing your XF yourself? What have you tried so far?
Customer: I would like to fix the car myself
JA: Anything else you want the mechanic to know before I connect you?
Customer: nope
Submitted: 5 months ago.
Category: Jaguar
Expert:  Richard replied 5 months ago.
Is the touchscreen completely black or it is flashing the gray logo screen?
Customer: replied 5 months ago.
The screen is completely black. Also, I can't power on the climate system. Sounds like modules? I just purchased the vehicle.
Expert:  Richard replied 5 months ago.

Yes this very well could be as sometimes there is an issue with water under the driver seat getting into those modules. It also could be a battery issue as low voltage can be the cause. I also recommend we check some fuses. Please check fuse #26 (15 amp) and #27 (10 amp) in the rear fuse box in the trunk and fuse #30 (10 amp) in the central junction box in the passenger side kick panel. Let me know,

Customer: replied 4 months ago.
The fuses checked out good.
Expert:  Richard replied 4 months ago.

Ok then we could have a problem with a number of modules for that system. On these sometimes water can leak into the vehicle and collect under the driver seat causing the issue.

Customer: replied 4 months ago.
Thanks. There are water in the car when I bought it, significant amount. How can I test out the wires to ensure continuity and each module's functionality?
Expert:  Richard replied 4 months ago.
Hard to test that part of the system. I recommend we remove the left front seat and check the modules and harness connection for damage.
Customer: replied 4 months ago.
Richard. I have both seats removed along with the carpet. When I received the car, the four modules under the seats were removed and placed in the trunk. The car's carpet was soaked with water. The seller said the salvaged car was not totaled because of flooding, but due to an accident. I do know sunroof would not retract fully, thus it may have created the reason for the water in the vehicle. I checked the fuses and the relays. When I removed fuse #26 in the RJB and reinserted it, the center console came on displaying the Jaguar logo (I assume it rebooted the system) and then went off. My objective is to get the center console (information center) to come on so I can operate the climate controls, radio, etc.. I have a repair shop wanting to run a pin test to evaluate the network, power, grounds. I am trying to avoid be charged to do work that I can do. I hope you can help me with this repair.
Tim(###) ###-####
Expert:  Richard replied 4 months ago.

Are all the modules re installed? Any damage to the wire harness and cables for those modules?

Customer: replied 4 months ago.
Richard, as you know, there are three modules under the driver's seat. The wiring harness looks in tact, however, there is one wire not connected to the Sirus radio module, see photos. On the passenger's side, there is one module the electronic control module (ECM), this module also has a red wire not connected. See pictures.
Customer: replied 4 months ago.
Correction ECU, not ECM.
Expert:  Richard replied 4 months ago.

For the audio modules that link harness should be able to be replaced. We need to start with getting that module powered up. For the other side that is the tire pressure module and that pin will need to be replaced and the rest of the connectors checked as more wires may b corroded and damaged.

Customer: replied 4 months ago.
Okay, so if I understand you, we are going to work getting the driver's side functional first? I just order a new wiring harness for the passenger's side. See picture. http://i.ebayimg.com/images/g/GlkAAOSwv9hW3yms/s-l1600.jpg
I could not locate the wiring harness for the driver's side. What should I do at this point?
Customer: replied 4 months ago.
I just ordered a wiring harness for the driver's side. As we discussed, there are four modules in the car:
Driver's side:
C241471, Satellite Receiver Module--Just ordered one for $80.00. It appears that one of the pins in the module was defective/broken off.
C2Z11365, Telephone Bluetooth
C2P19340, Stereo Audio Radio Module
Passenger's Side:
C2P25960, Tire Pressure Module (ECU)
What's the troubleshooting strategy we are going to take?
Expert:  Richard replied 4 months ago.

Yes replace all those damaged modules and the wire harness. The modules under the driver seat are for the audio/infotainment system. The module under the passenger seat is for the tire pressure monitoring. Once all the damaged parts are replaced the system should work unless there are other issues.

Customer: replied 4 months ago.
Richard, will the climate control system come on based on replacing the wires/modules under the driver's seat?
Expert:  Richard replied 4 months ago.

This should get the screen working so we should be able to get to the climate screen however there is another seperate climate module on the side of the heater box.

Customer: replied 4 months ago.
Richard--this is a picture of the CJB, notice the missing relays (R2 and R3) is this normal? I could not locate them in the fuse diagram.
Customer: replied 4 months ago.
Richard, all the modules came in today, bumper no success.
Customer: replied 4 months ago.
Richard, all the modules came in today, bummer no success.
Expert:  Richard replied 4 months ago.

Yes those relay spots are open. Did you replace that damaged harness.

Customer: replied 4 months ago.
I did.