How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask peterpete190 Your Own Question
peterpete190, Auto Technician
Category: Jaguar
Satisfied Customers: 24182
Experience:  Auto repair Technician with 17 years experience.Past ASE and other certifications.
Type Your Jaguar Question Here...
peterpete190 is online now
A new question is answered every 9 seconds

1990 JAG XJS V-12 run problem. Will start and run for one to

Customer Question

1990 JAG XJS V-12 run problem. Will start and run for one to two minutes and then die. Will restart after a minute or two and repeat the same problem. Have replaced fuel pump and Filter to no avail. Where do I start looking for a bad sensor. Thanks
JA: Which particular sensor are you asking about? And have any trouble codes been triggered?
Customer: 1990 Jags XJS V-12 did not have codes to my knowledge.
JA: Are you fixing your XJS V12 yourself? What have you tried so far?
Customer: I am a dam good mechanic but no knowledge of Jags.
JA: Anything else you want the mechanic to know before I connect you?
Customer: no
Submitted: 20 days ago.
Category: Jaguar
Expert:  peterpete190 replied 15 days ago.

My name is ***** ***** I am a professional here at Just Answer. I noticed that your question had not received a response and thought I would see if you still need help with this.I apologize for the delay and I hope I can still assist you with this here.

If this model is equipped with a crank sensor (as some have) this will cause this type of fault here and is common to not set any fault codes which can make it difficult to diagnose.I would have this checked to see if the crank sensor is the cause here with it needing replaced to correct this fault.If this is or was checked into and found o.k. let me know before rating my help so we can continue here.

If more help is needed, use the reply tab to continue our conversation. If no further assistance is needed, kindly rate my service,your 5 star rating is appreciated.You can rate at any time and we can continue to work on your question as this will not close out your question.Keep in mind in some cases it can be difficult to fully diagnose or help repair your vehicle without seeing it and I work on delivering the best possible answer from what I see to work with.

Thanks Pete

Customer: replied 11 days ago.
Thanks for your efforts. So far nothing that we have tried has solved the problem. Crank sensors are clean and not corroded, fuel pump and filter replaced, injectors and fuel rails replaced and gas tank cleaned. More information for you. This car sat for 10 years in a barn. Any more seggestions?
Expert:  peterpete190 replied 11 days ago.

Since it sat for so long in a barn check and see if there are any chewed up or damaged wires in the engine bay.I have seen mice make nests under hood as well as in fuse panels,etc. that can cause issues like this here.If this was already checked or is checked and found o.k. let me know so we can continue.

Thanks Pete

Related Jaguar Questions