How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Richard Your Own Question
Richard
Richard, Jaguar Technician
Category: Jaguar
Satisfied Customers: 15342
Experience:  12 years at a Ford/Lincoln Mercury and Jaguar dealer as technician and shop foreman.
10437779
Type Your Jaguar Question Here...
Richard is online now
A new question is answered every 9 seconds

I have the same problem and the pedale switch is tested and

Customer Question

hello,
JA: Hi. What do you want help with?
Customer: I have the same problem and the pedale switch is tested and replaced (OK). Do you know what else can be the root cause for that?
JA: What is the model/year of your Jaguar?
Customer: XK8, 1997.
JA: Are you hoping to fix this yourself? What have you tried so far?
Customer: Yes. I will do it myself
JA: Anything else you think the mechanic should know?
Customer: I can drive if I push on the small button closed to the gearbox. I can drive correctly.
Submitted: 3 months ago.
Category: Jaguar
Expert:  Richard replied 3 months ago.
Can you give me a full description of your problems? What fault warning lights or messages on if any?
Customer: replied 3 months ago.
There is no default on the dashbord.
The gearbox is bocked at the P position. I have change the break pedal sensor. I can unblocked the gear box by pressing a small button closed to the "p" position.
There is no light (rear light) when I presse the brake. I have check the fusible.
Expert:  Richard replied 3 months ago.
both the brake lights in the tail lights are not working as well as the high mount on the trunk?
Customer: replied 3 months ago.
I have the light on the central gear box (red light). But no rear light when I use the brake; The rear light is working only if I use the light swich off/one (during the night).
Expert:  Richard replied 3 months ago.
Go to the brake switch. With the ignition ON we need to make sure we have ground on pin 4 black wire. Then depress the brake and make sure we have ground on pin 1 green/black. We need to test this with a digital multimeter. Let me know.
Customer: replied 3 months ago.
Hello. Very good new !! It works now with additional cable to the ground. Brake sensor tested: ok. Do you know how to fix it?
Rear light works also with the cable. Thanks a lot
Expert:  Richard replied 3 months ago.
This tells us we have either a bad ground or problem in the wire harness. Since that pin 1 comes right from the ignition switch it is most likely a bad splice. We can try and locate the in line connector for that as there may be corrosion there. We are looking for pin 2 black wire on the in line 20 way yellow connector located on the lower right side dash connector bracket. You can also splice in a new wire in a few different spots like pin 1 of the inertia switch which is next to the left hand side dash fuse box.

Related Jaguar Questions