How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Richard Your Own Question
Richard
Richard, Jaguar Technician
Category: Jaguar
Satisfied Customers: 15342
Experience:  12 years at a Ford/Lincoln Mercury and Jaguar dealer as technician and shop foreman.
10437779
Type Your Jaguar Question Here...
Richard is online now
A new question is answered every 9 seconds

I have an electrical issue with my 2004 Vanden Plas

Customer Question

Hello, I have an electrical issue with my 2004 Vanden Plas
Submitted: 8 months ago.
Category: Jaguar
Expert:  Richard replied 8 months ago.
Hello.What kind of issue are you having?
Expert:  Richard replied 8 months ago.
Hello.What kind of issue are you having?
Customer: replied 8 months ago.
My car sat for a couple weeks while I was replacing my intake manifold gaskets (waiting for parts to come in) and the battery died. I tried to jump start it using my battery charger (it has a setting for "start car"). It did not work so I bought a new battery, H8, and now it starts and drives fine. However the following electrical items do not work now (they were working before the battery died):
-All power windows
-Interior lights
-Glove box, trunk and fuel door solenoids
-Front headlights, fog lamps, turn signals. All of the rear lights work fine.
I checked all the fuses with a multi-meter or by pulling them out and they are all OK. The grounds in the trunk and behind the front headlamps appear corrosion free and tight.
Are there some fusible links that I might have blown or relays that got damaged by trying to jump start?
Also, when I tried to jump start it, I put the battery charger cables on the pos and neg terminals of the battery.
Customer: replied 8 months ago.
I did try to "reset" the electrical system by disconnecting the battery terminals for a few hours and this did not work. Also, the check engine light is not on.
Customer: replied 8 months ago.
Posted by JustAnswer at customer's request) Hello. I would like to request the following Expert Service(s) from you: Live Phone Call. Let me know if you need more information, or send me the service offer(s) so we can proceed.
Customer: replied 8 months ago.
Hello, I have not received a reply, but have been asked to rate you...
Expert:  Richard replied 8 months ago.

OK most all these functions are controlled by the Front Electronics Module. This module is located behind the driver side kick panel. We need to make sure all the connections there are clean and secure. Also check the grounds there. Also see if the passenger side mirror moves and the front heated seats work if fitted. If neither work then we need to check powers and grounds to that FEM. Let me know.

Customer: replied 8 months ago.
OK, thanks for the information. I will be able to look into this on Saturday and let you know what I find. Also, both rear view mirrors work fine right now.
Expert:  Richard replied 8 months ago.

OK let me know.

Customer: replied 8 months ago.
I was able to check this out today and the connections and ground to the FEM are clean and tight. The heated seats do not heat up, although the switches on the dash "light up" when pressed. Also, the passenger side mirror does not work, only the drivers side works.Thanks
Customer: replied 8 months ago.
I removed the FEM and removed the cover. The electronics inside look OK, no burn marks, and the caps do not look blown or bulged out. I just have a few questions now:-If a get a used FEM, does it have to be taken to the dealer to get programmed?
-Can an independent shop do this programming?
-Do you have a "ballpark" cost for this?
-Can I just bring the replacement FEM to get programmed or the whole car?
-My part number ends with "AG". Do I have to get the "AG" model or can I get one with a "BB", "AH", "BE", designation? The ebay compatibility chart shows other part numbers working with all XJ8's from 2004 to 2009.Thanks
Expert:  Richard replied 8 months ago.

Yes the FEM will need to be programmed to the vehicle and yes the module will need to be installed in the vehicle. a new part is no longer available and there are a few VIN breaks. The module will need to be from a vehicle with the last six before G42680.

Related Jaguar Questions