How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Matt Your Own Question
Matt
Matt, Engineer
Category: Jaguar
Satisfied Customers: 20614
Experience:  Mechanical Engineer with 20 years experience in the auto industry, 8 yrs in formula 1 engine testing
12772297
Type Your Jaguar Question Here...
Matt is online now
A new question is answered every 9 seconds

I have same problem as many others I guess - X-type 2.0

Customer Question

Hi, I have same problem as many others I guess - X-type 2.0 diesel 2005 started smoking when accelerating, and engine fault indicator light came on. Checked and cleaned EGR-valve (looked ok)- no go. Disconnected and plugged vacuum hose to EGR, smoke disappeared but engine running a little bit rougher. Changed MAF-sensor and connected vacuum hose again, same problem with black smoke, light did not go off. Disconnected and plugged vacuum hose again, drove car for 2 months but yesterday glow plug light started flashing and engine. stopped and will not start. Any ideas? Thanks, ***** ***** Norway
Submitted: 1 year ago.
Category: Jaguar
Expert:  Matt replied 1 year ago.

Hello

On any car if you get a check engine light or other fault light this typically means one or more of the sensors has failed or has a faulty connection.

The fault can be something quite simple and nothing that’s going to stop the car to something quite major that will reduce engine power and possibly stop the engine

The ECU senses this and may put the car into 'limp home' mode which typically limits the revs and the amount of power available. Usually the car is safe to drive for a short distance as the mode is intended is intended to get you home without incurring any engine damage

The quickest route to repair is to have the car plugged into a diagnostic machine which will read off the fault code stored in the ECU (providing the light is still on at this point) and indicate which sensor has failed or whether the fault is more serious.

You can do a very rough and ready check yourself by unplugging sensors one at a time and seeing if any of them change the driving condition which would indicate the most recently unplugged sensor is the faulty one. This method is not foolproof though and reading a fault code off is the better method.

You can also try resetting the car by removing both battery leads and clamping them together for 10 mins as this will reset everything so if the light re-appears then the fault is still there.

Disconnect the battery cables and clamp them together for 10 mins. Remove both battery leads from the battery then use a nut and bolt or G-clamp to hold both battery lead terminals together.

This discharges any capacitors / memory within the ECU and around the car so ensures all memory settings are wiped clear - back to the factory default.

This will reset all the systems on the car and you may need the radio security code to get it going again, and ensure that the keys are in your hand when you re-connect the battery as the car may lock and turn on the alarm

Expert:  Matt replied 1 year ago.

Hi

do you still need help?

Bear in mind that the site takes a deposit from you at the beginning and this is held by the site until you rate my answer at which point the cash is split between the site and the expert. so if my answers have been helpful please rate my answer.

Related Jaguar Questions