How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Richard Your Own Question
Richard
Richard, Jaguar Technician
Category: Jaguar
Satisfied Customers: 15467
Experience:  12 years at a Ford/Lincoln Mercury and Jaguar dealer as technician and shop foreman.
10437779
Type Your Jaguar Question Here...
Richard is online now
A new question is answered every 9 seconds

I have a 1997 XK8 Convt and have intermittant limp home mode

Customer Question

Hi Richard, I have a 1997 XK8 Convt and have intermittant ***** *****mp home mode and check engine. When they go off the car runs and shifts great. It has a new batt and alt. When I start the amber is on with reduced power,then when it warms up - 10-15min of drive time it goes on/off/on/off then runs fine. Currently the Cruse control doesn't operate, and the lights on the j-shift go out intermittently. Its got 96K on it
Submitted: 1 year ago.
Category: Jaguar
Expert:  Richard replied 1 year ago.

When the lights on the shifter go out is that when the warning comes on? Can I have the last six of your VIN?

Customer: replied 1 year ago.
Hi Richard,
Its variable but generally I'll notice the light's are out after the amber comes on. I get Gearbox Fault, Engine Malfunction messages mostly. SAJGX2743VC010558 is my VIN. I believe it has the original throttle body.
Expert:  Richard replied 1 year ago.

Thanks. I was going to say that we may have a problem with the throttle but since we lose gear shift illumination this may be a problem with the communication network and I actually have seen of few instances of the gear shift illumination module causing this. To be sure we will need to have the vehicle scanned for the stored fault codes. A Jag factory tool is needed to do this but we can try a generic OBD II available at your local parts store to see if we can read any faults.

Customer: replied 1 year ago.
Thanks Richard ill grab the codes and reply
Expert:  Richard replied 1 year ago.

Ok sounds good.

Customer: replied 1 year ago.
Hi Richard,
The codes I pull are P0706 and P1797. The cruise control on/off switch led goes off and on as well. At time the illumination around the shifter goes out but not with any consistancy.
Expert:  Richard replied 1 year ago.

Ok looks like we may have a problem with the transmission rotory switch causing this. That is the switch on the actual transmission. Another possibility is the D4 micro switch inside the shifter or the shifter cable itself.

Customer: replied 1 year ago.
Thanks Richard! what the best way to decide which one? rotary switchs are big bucks so i want to be sure. 5
Expert:  Richard replied 1 year ago.

Hard to say without catching the problem in the act while monitoring the sensors. What you can do is see if we can get the problem to occur when moving the shifter from D to 4 as this would be the D 4 switch

Customer: replied 1 year ago.
I erased the codes and removed the battery cables for a few minutes to reset the car. Started it and plugged in the code reader. Moving the shifter from D to 4 doesnt seem to trigger anything abnormal. Car runs great. Powering the cruise will work, led on, but then it wont engage and it will randomly went out as well. 10-20 minutes into the drive the light amber goes on, gearbox fault, engine malfunction flashed, illumination on jgate out. led on the cruise button flashed on an off once, then off. Stopped the car cycled the ignition car ran great but check eng light on now. p0706 code. instruments worked fine but the dash light seemed to pulse once in the middle of all that activity.
Expert:  Richard replied 1 year ago.

Ok it is most likely a bad rotory switch on the transmission. Try driving without engaging cruise control and see what happens.