How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask peterpete190 Your Own Question
peterpete190
peterpete190, Auto Technician
Category: Jaguar
Satisfied Customers: 24656
Experience:  Auto repair Technician with 17 years experience.Past ASE and other certifications.
14928985
Type Your Jaguar Question Here...
peterpete190 is online now
A new question is answered every 9 seconds

Jaguar x type 3.0: 04 X-Type, 3.0, 73k miles. I'm a dealer,

Customer Question

04 X-Type, 3.0, 73k miles. I'm a dealer, and purchased this car from Manheim Phoenix. I purchased a 14 day inspection and receive the car today. the battery was dead, no big deal right, so I charge the battery for a couple hours, started the car, and everything seems to be working perfectly. the AC the radio everything worked perfectly it ran and drove fine. I park the car for about 5 hours. and my customer checked the car out. he started it and noticed immediately that the AC the radio other electrical things we're not working. he also said that it was hard to get in to reverse and a lot of warning lights were lit up on the dash. the battery had time to drain back down if it was weak, could it be the battery? The car started pretty easily, but the electrical system is half inop , On my way home soonreally screwed up.
Submitted: 1 year ago.
Category: Jaguar
Customer: replied 1 year ago.
(Posted by JustAnswer at customer's request) Hello. I would like to request the following Expert Service(s) from you: Live Phone Call. Let me know if you need more information, or send me the service offer(s) so we can proceed.
Expert:  peterpete190 replied 1 year ago.
My name is ***** ***** I am a professional here at Just Answer. I noticed that your question was not getting a response and thought I would see if you still need help with this.I apologize for the delay and I hope I can still assist you with this here.
From what is described here this sounds like a low voltage issue and may be due to a battery at fault needing replaced or alternator not charging properly or may be an issue with a battery drain causing this fault here.The battery electronics need tested further to see if a fault can be located and repaired to correct this here.
Thanks Pete

Related Jaguar Questions