How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Curtis B. Your Own Question
Curtis B.
Curtis B., Technician
Category: Industrial Equipment
Satisfied Customers: 627
Experience:  Technican turned service manager on multiple lines of equipment used in industry.
30244710
Type Your Industrial Equipment Question Here...
Curtis B. is online now
A new question is answered every 9 seconds

I have a mpb040 Yale. Have a flashing single light at the

Customer Question

I have a mpb040 Yale. Have a flashing single light at the brain box when switch is on. Nothing works
Submitted: 8 months ago.
Category: Industrial Equipment
Expert:  Bradley Martin replied 8 months ago.

Can you read what the voltage the lift is supposed to run off of at the data plate I think that is a 36 volt truck

Expert:  Bradley Martin replied 8 months ago.

What color is the flashing light?

Customer: replied 8 months ago.
Red. It is a single light. I have 3 of these jacks. 24 volt system. This is not the led lights on the charger. When you turn the switch on the light is supposed to come on and flas about one time and go off.
Expert:  Bradley Martin replied 8 months ago.

Ok I am researching now

Expert:  Bradley Martin replied 8 months ago.

How many led lights are flashing ?

Customer: replied 8 months ago.
Ok
Expert:  Bradley Martin replied 8 months ago.

Have you checked the fuses?

Customer: replied 8 months ago.
There is only one and it is located at the bottom of the brain box
Customer: replied 8 months ago.
It just hangs there
Customer: replied 8 months ago.
on the fuses
Expert:  Bradley Martin replied 8 months ago.

Here is a picture check number 11 fuse and number 12 fuse

Expert:  Bradley Martin replied 8 months ago.

Also check the control arm switches make sure they are not stuck closed

Customer: replied 8 months ago.
I am not there now how ever I did check those fuses and they seemed fine. The control arm switch, is it at the base of the handle?
Expert:  Bradley Martin replied 8 months ago.

Ok and Yes the switches are at the base if they are stuck it will not power up correctly let me know when you get around the lift

Customer: replied 8 months ago.
I can go in tomorrow. Is that ok?
Expert:  Bradley Martin replied 8 months ago.

I will be busy most of the day but I will have my laptop and can be around to answer questions

Customer: replied 8 months ago.
Also, how can I check it. There is a light at the bottom that is supposed to tell you there is power and it is on but when you move the handle back to engage it there is no click to let you now it is ready
Expert:  Bradley Martin replied 8 months ago.

Sounds like a wiring issue you might have a broken wire at one of the switches I can send a wire schematic the first place I would look is the switches at the base they bend back and forth and over time can break you can check the with a volt meter set to ohms to watch the switch open and close we can talk on the phone if you would like for an additional charge

Customer: replied 8 months ago.
Ok, will check it in the morning and go from there. May have to bite the bullet and call
Expert:  Bradley Martin replied 8 months ago.

Ok just let me know I will send the schematic

Customer: replied 8 months ago.
seems I have power to the switch at the bottom of the handle. When I pull the handle back to engage the light on the switch comes on. I have 3 of these jacks so I swapped that switch and still nothing. The switch I took off the bad jack works the other jack so I know that was not it
Expert:  Bradley Martin replied 8 months ago.

You will need to check the wiring from the switches to the controller also need to check the wiring to the contactors are you able to view the schematic I sent

Related Industrial Equipment Questions