How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Bradley Martin Your Own Question
Bradley Martin
Bradley Martin,
Category: Industrial Equipment
Satisfied Customers: 175
Experience:  Field Technician at Thompson Tractor Company
29889544
Type Your Industrial Equipment Question Here...
Bradley Martin is online now
A new question is answered every 9 seconds

I'm working on a z45/22 lift the lift has gotten slow. I

Customer Question

I'm working on a z45/22 lift the lift has gotten slow . I checked the pressure it was at 1900 lbs so I adjusted it up to the spec. at 2200# When timing the lift speed it is at about half speed of the spec for this lift. My question is , is there a speed adjustment of any kind?
Submitted: 1 year ago.
Category: Industrial Equipment
Expert:  Bradley Martin replied 1 year ago.

There is no speed adjustment. You can adjust the pressure all day long and it will not help. Your problem is your flow not pressure the piggyback pump on the back of the drive pump has worn and is not creating the flow that it needs to perform at optimal speed. I would replace that aluminum pump.

Customer: replied 1 year ago.
I also talked with ou local genie dealer they claim that there is a electric speed control built into the controls system. I went on the net and went through the procedure and couldn't get the voltages to adjust. This adjustment is on a printed circuit board, perhaps there is other damage or problems.
.
Customer: replied 1 year ago.
H
Expert:  Bradley Martin replied 1 year ago.

I have never adjusted the speed on the circuit board that is preset from the factory I still think your piggyback pump is worn

Expert:  Bradley Martin replied 1 year ago.

found some more info let me know when your around the lift.

Customer: replied 1 year ago.
I am around the lift today respond back and give me your new plan
Expert:  Bradley Martin replied 1 year ago.

Under the upper controls there should be some adjustments you can do to ramp up the speed.Have you adjusted any of those yet?

Customer: replied 1 year ago.
The only thing I've adjusted is pressure and the screws that are in the circuit boards.
Expert:  Bradley Martin replied 1 year ago.

Which circuit board the one under the upper control panel?

Customer: replied 1 year ago.
in the controle box that is in the basket one screw says ramp on it these are the screws that when adjusted you check voltage as you adjust them. The voltage did not seem to change that is why I am questioning the circuit boards I don't know that's why I seek others wisdom.
Expert:  Bradley Martin replied 1 year ago.

If you have voltage going to the board and it is not changing when you adjust the pots. I would start with a board if it was me if that does not solve the problem my next cause would be that pump. What is the color of the hydraulic oil?

Customer: replied 1 year ago.
I'm still waiting for the new pump to come.
Expert:  Bradley Martin replied 1 year ago.

Ok please update me when you get it going and please rate me when you have a chance