How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask spankyjr1 Your Own Question
spankyjr1
spankyjr1, Journeyman
Category: Industrial Equipment
Satisfied Customers: 2516
Experience:  I worked on all types of equipment semis,forklifts,farm,ect.
65057319
Type Your Industrial Equipment Question Here...
spankyjr1 is online now
A new question is answered every 9 seconds

I have a Power boss 9XR ride on sweeper ,it is hard to start

Customer Question

I have a Power boss 9XR ride on sweeper ,it is hard to start ,thought it was a vacuum manifold problem as it is on gas ,have gas to PBR and electronic shut off .
it actually surprised us we put a set of spark plugs in it and it started straight away and we thought it was resolved 2 hrs later thought I would just check and it ran at really low idle cut out and wont start again.
Can you help
Cheers Mal
Submitted: 1 year ago.
Category: Industrial Equipment
Expert:  spankyjr1 replied 1 year ago.

Hi Mal my name is ***** ***** you for your question.

I have a few questions before I can give you a answer hope you don't mind.

You say it's on gas, do you mean petrol or LP fuel?

These are available in LP,Gas, and diesel, I eliminated diesel since you changed plugs.

When it does not start have you checked for spark at plugs?

Have you tried running on ether so we can confirm its a fuel problem?

It sounds like it's either a fuel problem or the hydraulics are not disengaging and its trying to start with them activated, which will make it turn over slow and not start since it has to much of a load on it.

Also make sure fuel shut off has power with ignition on and during cranking,,check voltage to make sure its not dropping out during cranking.

Let me know

Customer: replied 1 year ago.
Hi
It is lpg dedicated only , has new plugs, good spark, solenoid is operating.
Has several modules.
Has a PSI 1.6 gas engine ,hydraulics are disengaged.
can I upload a picture of the engine some how it is standard for this type of unit you may be able to check the service manual .I cant locate one but you may be able to.
Expert:  spankyjr1 replied 1 year ago.

Yes there should be a add picture button on your page, if not I see a lot of images added here through jing,,imgur,or another free image upload tool.

Have you tried running on ether so we can confirm its a fuel problem?

I'm off for today but I get online early so if you reply I will work on it first thing for you.

talk soon

spanky

Customer: replied 1 year ago.
It seems like a big hassle I may have to find someone local to assist and it it now starting to look very hands on.
Cheers
Expert:  spankyjr1 replied 1 year ago.

There is also a paper clip and link icon above the reply box that you type in to add links or pictures to reply box.

sorry about the issues, I'm just a user of the site like you and have no control over how it works, I have the same hassles you have.

I'm sure we could get it figured out and agree the site is difficult to use.

If you change your mind I will be around but leave in a week on vacation.

Best of luck to you.

Expert:  spankyjr1 replied 1 year ago.

Also if you could get me the engine model and serial numbers off engine tag I may be able to pull up that way?

Customer: replied 1 year ago.
mate its ok I will work it out
how do I unsubscribe from your site
Expert:  spankyjr1 replied 1 year ago.

There should be a contact customer service or contact us link on your page and let them know you don't want the subscription.

I don't get anything without a rating I'm just a user of the site and have no control over that part but if you do have any trouble let me know and I will send in too!

Best of luck to you

spanky

Related Industrial Equipment Questions