How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Jerry Your Own Question
Jerry
Jerry, Master Mechanic
Category: Hyundai
Satisfied Customers: 17218
Experience:  30 year ASE Master tech
2947720
Type Your Hyundai Question Here...
Jerry is online now
A new question is answered every 9 seconds

I have a 2002 Hyundai xg350L. I just changed my gh beams and

Customer Question

I have a 2002 Hyundai xg350L. I just changed my high beams and fog lights. Fogs work and low beams work great. High beams don't. I don't know why.
JA: Have you checked the bulbs? Have you checked the fuses?
Customer: I checked the both bulbs. There fine. Idk where the high beam fuses is to be honest.
JA: Are you hoping to fix this yourself? What have you tried so far?
Customer: Yes. I just replaced them. I had new zxe high beams. There went out. So I replaced them today. Myself.
JA: Anything else you think the mechanic should know?
Customer: I think that's it.
JA: OK. Got it. I'm sending you to a secure page on JustAnswer so you can place the $5 fully-refundable deposit now. While you're filling out that form, I'll tell the Hyundai Mechanic about your situation and then connect you two.
Submitted: 11 months ago.
Category: Hyundai
Expert:  Jerry replied 11 months ago.

Hello and welcome. My name is ***** ***** you for visiting the site.

Let me just say that any money that you paid, or if you have a subscription, that money stays in your account until the answers are rated, (positive) regardless of how fast or how long it may take to get finished. You can FOLLOW UP AT ANYTIME, even after rating.

You will want to check fuse #14 in the under hood fuse block. Please see attached diagrams. 15 amp fuse.

.

Please don’t forget to rate the answer in a positive way, . EVEN IF YOU HAVE A SUBSCRIPTION ****THAT IS THE ONLY WAY I GET PAID ****

Expert:  Jerry replied 11 months ago.

If you accept my additional service request for your email address, you can give me your email in a private info box and I'll send you the diagrams in a PDF file, the file is rather large.

You will just have to accept the additional service offer and ENTER your email address in the “ENTER CONTACT INFO” section so that I can see it.

I do not have access to your email address,

Customer: replied 11 months ago.
It's not the fuse.
Expert:  Jerry replied 11 months ago.

I see, thanks. It seemed that you didn't know where the fuse was, sorry.

Is there power to the relay? 2 terminals with the high beams on?

Customer: replied 11 months ago.
Expert:  Jerry replied 11 months ago.

That sounds like the switch. Is there a ground to one of the other terminals at the relay with the high beams are on?

Expert:  Jerry replied 11 months ago.

Where did you go?

Let me know if you need the tests for the switch or instructions, thanks

Customer: replied 11 months ago.
I found the problem. I just turn the light connectors wires and they came on.
Expert:  Jerry replied 11 months ago.

So, a bad connection at the bulbs? Good job, glad to hear that you found the problem, thanks and please come again, anytime.