How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Chris (aka- Moose) Your Own Question
Chris (aka- Moose)
Chris (aka- Moose), Technician
Category: Hyundai
Satisfied Customers: 44414
Experience:  16 years of experience
2499435
Type Your Hyundai Question Here...
Chris (aka- Moose) is online now
A new question is answered every 9 seconds

Tucson after removing instrument cluster speedometer and

Customer Question

Tucson after removing instrument cluster speedometer and tach do not work plus lights remain on
Submitted: 1 year ago.
Category: Hyundai
Expert:  Chris (aka- Moose) replied 1 year ago.

Welcome I'm Chris aka Moose

What was the original reason for removing the cluster?

-----------About me and Just Answer------------

I am in my upper 30's, have a wife and 2 sons. I farm, fish, hunt, build, and coach youth soccer. I work on anything with an engine, been to many schools and classes through my 12 years with the dealership to get trained and certified. I try the best I can to share what I know and or have access to with my customers. Please consider I base my questions and answers to you, solely on the information you give me since I am not there to see, smell, hear, touch, or test. I try my best to be here everyday starting at 3pm central. Rating an answer is required. Please let me know if your not pleased prior to rating or if you cannot rate me so I can try to help a different way. God Bless and have a great day.

Thanks Chris

Customer: replied 1 year ago.
wanted to see if I could remove tpms bulb because I got winter tires with no tpms ,didn't find one replaced cluster when I started engine tach and speedometer didn't work plus so called idiot lights stayed on
Expert:  Chris (aka- Moose) replied 1 year ago.

Thanks for the extra details, but on my end it shows you have closed your post.