How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Greg Your Own Question
Greg
Greg, import technician
Category: Hyundai
Satisfied Customers: 6808
Experience:  27 year and 16 year as shop owner, import technician
29331485
Type Your Hyundai Question Here...
Greg is online now
A new question is answered every 9 seconds

2010 accent. car starts and runs perfect however, car cuts

Customer Question

2010 accent. car starts and runs perfect however, car cuts off at a light, sometimes it will restart, sometimes I have to wait 5 to 20 min or so. At time when I start car rpm gauge does not work, so shut the car off and restart and RPM gauge works. I have no engine service light at all. So there is no codes. Does anyone what the problem is??????????
Submitted: 1 year ago via CarComplaints.com.
Category: Hyundai
Expert:  Greg replied 1 year ago.
Name is***** goal is to provide you with excellent service – if you feel you have gotten anything less, please reply back,
This is a possible cam or crankshaft sensor most likely crankshaft ,
This will not leave a code in most cases .
I take it this happens mostly when the engine is hot .
Other possible cause for a no code is your fuel pump is shorting out .
When you have a no start you need to check for spark no spark crank sensor have spark check for fuel no fuel ,fuel pump .
Need further assistance with this issue then please get back to me with the reply button and not the poor or bad service rate buttons .
This way i can get back to you and suggest other options or suggest another Expert .
Kindest regards Greg