How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Sean Your Own Question
Sean
Sean, HVAC Technician
Category: HVAC
Satisfied Customers: 167
Experience:  Owner HVAC company
64612473
Type Your HVAC Question Here...
Sean is online now
A new question is answered every 9 seconds

I have a Carrier Performance 80 with an Aprilair installed.

Customer Question

I have a Carrier Performance 80 with an Aprilair installed. The Apirlair will not power (never has worked well even when installed originally) and from what I have discovered it is the power from the board to the Aprilair unit that is defective.
JA: Did you double-check the thermostat's settings? And what about the filters?
Customer: Nothing to do with that.
JA: Do you plan on doing the work yourself?
Customer: If I can.
JA: Anything else we should know to help you best?
Customer: the 24v output on the board has no power - will the board have to be replaced?
Submitted: 1 month ago.
Category: HVAC
Expert:  airheatman replied 1 month ago.

Can you give me complete model from inside furnace in burner compartment so I can provide guidance with this specific unit.Model will be on a label just above burners on right or left inside panel

http://i.imgur.com/U8b0GXT.jpg

Customer: replied 1 month ago.
Performance 80
Customer: replied 1 month ago.
Don't worry about it.I will spend more money this way than calling out a tech.Thanks
Expert:  Sean replied 1 month ago.

Would you like to still try this, I just seen this question post?

I can help you probably pretty cheaply.

Customer: replied 1 month ago.
58CTA090-14
Series 110
Made Nov 2004
Customer: replied 1 month ago.
You do not have to call - just email.
Expert:  Sean replied 30 days ago.

I'm so sorry this just popped up saying you responded.

Let's see what we can come.up with.

So the aprilaire humidifer is the problem correct ?

Where is the humidifer hooked to at the board.

Customer: replied 30 days ago.
To the 24v puppy on the board but there is no voltage present.
Expert:  Sean replied 30 days ago.
24v should be coming out of board of furnace ?If you can take pictures of the board and where it's wired I can help you alot easier
Customer: replied 30 days ago.
I'll get to that tomorrow.
Expert:  Sean replied 29 days ago.

Ok no problem!

Expert:  Sean replied 26 days ago.

Do you want to continue

Expert:  Sean replied 25 days ago.

Just got back on and see your photos, excellent. Helps alot.

Alright first of all do you have a hundistat to control the humidity ?

2ndly that HUM terminal is that a for sure 24v

If you have a humidstat go on the control board R and C this is 99% of how I wire them and they will work fine, you really need a hundistat so it will turn on and off as needed

Customer: replied 25 days ago.
A controller is attached and wired properly from the research I did. The brown coated cable comes from there.
Expert:  Sean replied 25 days ago.
Great, so let's transfer thoese wires from r-c and give it a go.Then turn that hundistat all the way up you should hear a click at the solonoid at humidifer
Expert:  Sean replied 25 days ago.
Please also remember to put door on bottom other wise you you will not have 24v
Customer: replied 25 days ago.
The humidistat dose make the click when turned up (always has) but the unit will not work.
Expert:  Sean replied 24 days ago.
but we need to see if your hearing a click at the hundiifer solonoid.Did you rewire from hum terminal to R ?

Related HVAC Questions