How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask BillyHvac Your Own Question
BillyHvac, Journeyman HVAC Tech
Category: HVAC
Satisfied Customers: 21995
Experience:  Endorsed for unlimited heating, cooling, oil burners, boilers, refrigeration, hydronics
Type Your HVAC Question Here...
BillyHvac is online now
A new question is answered every 9 seconds

The temperature set point on my Raypak 2100 natural gas

Customer Question

The temperature set point on my Raypak 2100 natural gas heater keeps 'dumping' to 50 degrees, effectively shutting down any heating. I've replaced the board last year and it worked well...last year. This May, upon start up, the after setting the temp to 86 degrees, the heater fired when needed to maintain that temp. Recently, I'd find the set point stuck at 50 degrees. Sometimes, I'd be able to raise the set point up to where the call for heat would come on and the unit would fire. Other times, I'd have to recycle the on/off switch on the side to be able to move the set point off the 50 degree mark. In either case, the heater would fire up and heat for a bit, then the set point would 'dump' back to 50 degrees, shutting everything down. I've opened up the board panel several times, pushed on all the connections to be sure they were well seated. I've used canned air to blow around the board to make sure there wasn't any dust or spider webs in there. I'm not sure what else to do and surely hope I don't need to be replacing the board every year! I've got a big family party this Saturday and need the water to be warmer or else none of the adult women will go in! Help!
Thanks in advance!
Submitted: 2 months ago.
Category: HVAC
Expert:  BillyHvac replied 2 months ago.

I am very sorry your question has not been picked up yet.

I just logged on and found you had not been assisted.

Please let me know if you still need help and I will do my best. Please do not "Rate" as we have not worked toward an answer yet.

If you would like to proceed let me know by replying

Customer: replied 2 months ago.
Hi Billy,I've taken the board out, as well as the panel that has the temp and mode buttons. I've inspected and blew air all around to make sure everything was clean. I replaced the board last year and everything worked well all last season and from May when we opened the pool this season, up until about a week or so ago. I can get the system to call for heat and fire up burners firing just fine. It'll stay lit for a couple of minutes until the set point dumps down to 50 which of course shuts down the burners. I can't figure it out. There are no service codes. I'll send the manual I just downloaded from Raypak. I can't believe that the board lasted not even a full year. What do you think it could be?Thanks!
Customer: replied 2 months ago.
Hi!I still haven't gotten an answer. It's now 8-10-16. I originally submitted my question on 8-4-16....what gives?Thanks!

Related HVAC Questions