How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Gaztech Your Own Question
Gaztech
Gaztech, HVAC Technician
Category: HVAC
Satisfied Customers: 423
Experience:  Owner at Gaztech
92290868
Type Your HVAC Question Here...
Gaztech is online now
A new question is answered every 9 seconds

I have a 1999 robinair a/c machine its been in the back room

Customer Question

I have a 1999 robinair a/c machine its been in the back room of my shop trying to get it running the fan comes on the screen works the enter,vac,filter,hold buttons don't do any thing don't beep lick the others the motor dose work model 17700a
Submitted: 9 months ago.
Category: HVAC
Expert:  Gaztech replied 9 months ago.
Welcome to Just AnswerNOTE: I can only get paid for assisting you if you click FINISHED and RATE ANSWER after you are satisfied with answer.I will get right to the point.Your unit is for r12 only..is it worth fixin?Replace- Main Circuit Board , part number: RA19432
Customer: replied 9 months ago.
The AC machine is for R134 how can I test the keypad
Expert:  Gaztech replied 9 months ago.
I will leave anther expert assist you
Expert:  bonzaco replied 9 months ago.
Here's the user manual to get you started on the set up - come back to me when you get stuck - http://www.nytechsupply.com/downloads/refrigerant_recovery/robinair_17700_34700_operation_manual.pdf - Ian
Customer: replied 9 months ago.
I'm trying to figure out why charge ,hold,vac,enter button r not working all the other ones beep and work
Expert:  bonzaco replied 9 months ago.
Sounds like you have a keypad error - have you looked at the output to the vac pump to see if it receives any power during vac or cant you get it to work?
Expert:  Gaztech replied 9 months ago.
Try disconnecting reserve tank, bleed out all pressure from unit to rule out high pressure lookouts.